summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-18 11:48:18 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-18 11:57:52 +0200
commit5f23e374f6a8439c97cb44738bc12dff7be787e3 (patch)
tree2faabe99c0334a0db9f6b11c8202c9f04928e496 /sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild
parentapp-dicts/gwaei: Drop old (diff)
downloadgentoo-5f23e374f6a8439c97cb44738bc12dff7be787e3.tar.gz
gentoo-5f23e374f6a8439c97cb44738bc12dff7be787e3.tar.bz2
gentoo-5f23e374f6a8439c97cb44738bc12dff7be787e3.zip
sys-apps/gsmartcontrol: Stop relying in eapi4 support for gnome2-utils.eclass
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild')
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild
index 9fa1694f3a60..54f83512a642 100644
--- a/sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-
+EAPI=6
inherit flag-o-matic gnome2-utils
DESCRIPTION="Hard disk drive health inspection tool"
@@ -15,25 +14,28 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
-COMMON_DEPEND="dev-cpp/gtkmm:2.4
- dev-libs/libpcre
- sys-apps/smartmontools"
+COMMON_DEPEND="
+ dev-cpp/gtkmm:2.4
+ dev-libs/libpcre:3
+ sys-apps/smartmontools
+"
RDEPEND="${COMMON_DEPEND}
- x11-apps/xmessage"
+ x11-apps/xmessage
+"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
- test? ( dev-util/gtk-builder-convert )"
+ test? ( dev-util/gtk-builder-convert )
+"
DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
src_prepare() {
+ default
append-cxxflags -std=c++11
}
src_configure() {
- econf \
- --docdir=/usr/share/doc/${PF} \
- $(use test tests)
+ econf $(use test tests)
}
src_install() {