summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2018-01-21 21:41:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-24 20:52:12 +0100
commitfb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f (patch)
treebf56c2c80a49ad7d4c16c27df74cdf5437185391 /sys-apps/hd-idle
parentdev-db/etcd: Version bump to 3.3.0_rc4 (diff)
downloadgentoo-fb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f.tar.gz
gentoo-fb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f.tar.bz2
gentoo-fb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f.zip
sys-apps/hd-idle: new package.
Utility for spinning down hard disks after a period of idle time. Package-Manager: Portage-2.3.20, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6927
Diffstat (limited to 'sys-apps/hd-idle')
-rw-r--r--sys-apps/hd-idle/Manifest1
-rw-r--r--sys-apps/hd-idle/files/hd-idle-conf30
-rw-r--r--sys-apps/hd-idle/files/hd-idle-init12
-rw-r--r--sys-apps/hd-idle/hd-idle-1.05.ebuild26
-rw-r--r--sys-apps/hd-idle/metadata.xml16
5 files changed, 85 insertions, 0 deletions
diff --git a/sys-apps/hd-idle/Manifest b/sys-apps/hd-idle/Manifest
new file mode 100644
index 000000000000..043faa7b64e6
--- /dev/null
+++ b/sys-apps/hd-idle/Manifest
@@ -0,0 +1 @@
+DIST hd-idle-1.05.tgz 17951 BLAKE2B f99dd25d41f2ac4391025ff652827a8687db19df2dafe0f07eeeea700eaf0d67a255ee67017123510a3b89f3aba2f50de7204923d9ab85e80138f657f5e120d3 SHA512 8636d8bf2bce40f380afdea859aef7d142258071c62f87884a9af55c7c84310d89de712f56dff2bd825f0c7d79b04356df92e3012d8f683d8c41ebb23cd3920b
diff --git a/sys-apps/hd-idle/files/hd-idle-conf b/sys-apps/hd-idle/files/hd-idle-conf
new file mode 100644
index 000000000000..a0bd68336e2a
--- /dev/null
+++ b/sys-apps/hd-idle/files/hd-idle-conf
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# defaults file for hd-idle
+
+# hd-idle command line options
+# Options are:
+# -a Set (partial) device name of disks for subsequent
+# idle-time parameters (-i). This parameter is optional
+# in the sense that there's a default entry for all
+# disks which are not named otherwise by using this
+# parameter.
+# -i <idle_time> Idle time in seconds.
+# -l <logfile> Name of logfile (written only after a disk has spun
+# up). Please note that this option might cause the
+# disk which holds the logfile to spin up just because
+# another disk had some activity. This option should
+# not be used on systems with more than one disk
+# except for tuning purposes. On single-disk systems,
+# this option should not cause any additional spinups.
+#
+# Options not exactly useful here:
+# -t <disk> Spin-down the specfified disk immediately and exit.
+# -d Debug mode. This will prevent hd-idle from
+# becoming a daemon and print debugging info to
+# stdout/stderr
+# -h Print usage information.
+
+#HD_IDLE_OPTS="-i 180 -l /var/log/hd-idle.log"
+
diff --git a/sys-apps/hd-idle/files/hd-idle-init b/sys-apps/hd-idle/files/hd-idle-init
new file mode 100644
index 000000000000..650d1934a437
--- /dev/null
+++ b/sys-apps/hd-idle/files/hd-idle-init
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Utility for spinning down hard disks after a period of idle time"
+
+command="/usr/sbin/hd-idle"
+command_args="${HD_IDLE_OPTS}"
+
+depend() {
+ after bootmisc
+}
diff --git a/sys-apps/hd-idle/hd-idle-1.05.ebuild b/sys-apps/hd-idle/hd-idle-1.05.ebuild
new file mode 100644
index 000000000000..4da29a661672
--- /dev/null
+++ b/sys-apps/hd-idle/hd-idle-1.05.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="http://hd-idle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+CONFIG_CHECK="~PROC_FS"
+
+DOCS=( debian/changelog README )
+
+src_install() {
+ default_src_install
+ newinitd "${FILESDIR}"/hd-idle-init hd-idle
+ newconfd "${FILESDIR}"/hd-idle-conf hd-idle
+}
diff --git a/sys-apps/hd-idle/metadata.xml b/sys-apps/hd-idle/metadata.xml
new file mode 100644
index 000000000000..6a1a90c15b59
--- /dev/null
+++ b/sys-apps/hd-idle/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>o.freyermuth@googlemail.com</email>
+ <name>Oliver Freyermuth</name>
+ <description>Proxy-maintainer, assign bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hd-idle</remote-id>
+ </upstream>
+</pkgmetadata>