summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-19 21:25:44 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-19 21:29:38 +0100
commit5d1c197e7c700d5d3a8fcd6d0d880ce7ee269f45 (patch)
treef7a4e941a49bd3fa68593004247acd2fc6bd3d5a /sys-apps/hdparm/files
parentprofiles: Plasma 4 removal mask update (diff)
downloadgentoo-5d1c197e7c700d5d3a8fcd6d0d880ce7ee269f45.tar.gz
gentoo-5d1c197e7c700d5d3a8fcd6d0d880ce7ee269f45.tar.bz2
gentoo-5d1c197e7c700d5d3a8fcd6d0d880ce7ee269f45.zip
sys-apps/hdparm: Bump to version 9.51
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/hdparm/files')
-rw-r--r--sys-apps/hdparm/files/hdparm-9.51-build.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/hdparm/files/hdparm-9.51-build.patch b/sys-apps/hdparm/files/hdparm-9.51-build.patch
new file mode 100644
index 000000000000..2c6bdba68e3f
--- /dev/null
+++ b/sys-apps/hdparm/files/hdparm-9.51-build.patch
@@ -0,0 +1,32 @@
+* drop hardcoded -O2 flag from CFLAGS
+* drop hardcoded -s (strip) flag from LDFLAGS, and respect user LDFLAGS
+* fix hardcoded `make` and hardcoded -j2 flags
+* respect CFLAGS when linking
+
+--- hdparm-9.51/Makefile
++++ hdparm-9.51/Makefile
+@@ -13,9 +13,8 @@
+ CC ?= gcc
+ STRIP ?= strip
+
+-CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
++CFLAGS += -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs
+
+-LDFLAGS = -s
+ #LDFLAGS = -s -static
+ INSTALL = install
+ INSTALL_DATA = $(INSTALL) -m 644
+@@ -24,11 +23,10 @@
+
+ OBJS = hdparm.o identify.o sgio.o sysfs.o geom.o fallocate.o fibmap.o fwdownload.o dvdspeed.o wdidle3.o
+
+-all:
+- $(MAKE) -j4 hdparm
++all: hdparm
+
+ hdparm: hdparm.h sgio.h $(OBJS)
+- $(CC) $(LDFLAGS) -o hdparm $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o hdparm $(OBJS)
+ $(STRIP) hdparm
+
+ hdparm.o: hdparm.h sgio.h