summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <stha09@googlemail.com>2020-03-26 16:34:52 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-26 19:46:42 +0200
commitf13ea5002842f34785a6a9d4938d6b3001d3002b (patch)
tree5ab64e592c5dba149fc833c896020854014a8f6c /sys-apps/heirloom-tools
parentdev-python/nose: Coverage supports py3.8 now (diff)
downloadgentoo-f13ea5002842f34785a6a9d4938d6b3001d3002b.tar.gz
gentoo-f13ea5002842f34785a6a9d4938d6b3001d3002b.tar.bz2
gentoo-f13ea5002842f34785a6a9d4938d6b3001d3002b.zip
sys-apps/heirloom-tools: fix some QA issues, EAPI 7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Stephan Hartmann <stha09@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/15127 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps/heirloom-tools')
-rw-r--r--sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch16
-rw-r--r--sys-apps/heirloom-tools/heirloom-tools-070715-r3.ebuild (renamed from sys-apps/heirloom-tools/heirloom-tools-070715-r2.ebuild)35
2 files changed, 45 insertions, 6 deletions
diff --git a/sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch b/sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch
new file mode 100644
index 000000000000..a4ce2970589d
--- /dev/null
+++ b/sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch
@@ -0,0 +1,16 @@
+diff --git a/Makefile.mk b/Makefile.mk
+index 28a20f1..1cf36b8 100644
+--- a/Makefile.mk
++++ b/Makefile.mk
+@@ -73,11 +73,6 @@ links:
+ sh build/crossln $(ROOT)$(SV3BIN)/more $(ROOT)$(UCBBIN)/more $(ROOT)
+ rm -f $(ROOT)$(UCBBIN)/catman
+ sh build/crossln $(ROOT)$(DEFSBIN)/catman $(ROOT)$(UCBBIN)/catman $(ROOT)
+- for i in sccs prt; \
+- do \
+- rm -f $(ROOT)$(UCBBIN)/$$i; \
+- sh build/crossln $(ROOT)$(CCSBIN)/$$i $(ROOT)$(UCBBIN)/$$i $(ROOT); \
+- done
+ rm -f $(ROOT)$(SV3BIN)/awk
+ sh build/crossln $(ROOT)$(DEFBIN)/oawk $(ROOT)$(SV3BIN)/awk $(ROOT)
+ rm -f $(ROOT)$(S42BIN)/awk
diff --git a/sys-apps/heirloom-tools/heirloom-tools-070715-r2.ebuild b/sys-apps/heirloom-tools/heirloom-tools-070715-r3.ebuild
index f45cc2e1c880..34e2e70756e4 100644
--- a/sys-apps/heirloom-tools/heirloom-tools-070715-r2.ebuild
+++ b/sys-apps/heirloom-tools/heirloom-tools-070715-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Heirloom toolchest - original Unix tools"
@@ -15,8 +15,8 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
sys-libs/zlib
"
-DEPEND="
- ${RDEPEND}
+DEPEND=${RDEPEND}
+BDEPEND="
sys-apps/ed
sys-devel/bc
virtual/pkgconfig
@@ -24,6 +24,7 @@ DEPEND="
S="${WORKDIR}/heirloom-${PV}"
PATCHES=(
"${FILESDIR}"/${P}-major.patch
+ "${FILESDIR}"/${P}-makefile.patch
"${FILESDIR}"/${P}-glibc-2.30.patch
"${FILESDIR}"/${P}-glibc-2.31.patch
"${FILESDIR}"/${P}-gcc-10.patch
@@ -43,17 +44,39 @@ src_compile() {
CPPFLAGS="${CPPFLAGS}" \
LCURS="$( $(tc-getPKG_CONFIG) --libs ncurses)" \
LDFLAGS="${LDFLAGS}" \
+ ROOT="${ED}" \
+ DEFBIN="/usr/bin/${PN}/5bin" \
+ DEFSBIN="/usr/bin/${PN}/5bin" \
+ SV3BIN="/usr/bin/${PN}/5bin" \
+ S42BIN="/usr/bin/${PN}/5bin/s42" \
+ SUSBIN="/usr/bin/${PN}/5bin/posix" \
+ UCBBIN="/usr/bin/${PN}/ucb" \
+ CCSBIN="/usr/bin/${PN}/ccs/bin" \
+ SU3BIN="/usr/bin/${PN}/5bin/posix2001" \
+ DEFLIB="/usr/bin/${PN}/5lib" \
LIBZ=-lz
}
src_install() {
# we don't want to strip here, so use "true" as noop
- emake STRIP="true" ROOT="${D}" -j1 install
+ emake -j1 \
+ STRIP="true" \
+ ROOT="${ED}" \
+ DEFBIN="/usr/bin/${PN}/5bin" \
+ DEFSBIN="/usr/bin/${PN}/5bin" \
+ SV3BIN="/usr/bin/${PN}/5bin" \
+ S42BIN="/usr/bin/${PN}/5bin/s42" \
+ SUSBIN="/usr/bin/${PN}/5bin/posix" \
+ UCBBIN="/usr/bin/${PN}/ucb" \
+ CCSBIN="/usr/bin/${PN}/ccs/bin" \
+ SU3BIN="/usr/bin/${PN}/5bin/posix2001" \
+ DEFLIB="/usr/bin/${PN}/5lib" \
+ install
}
pkg_postinst() {
- elog "You may want to add /usr/5bin or /usr/ucb to \$PATH"
- elog "to enable using the apps of heirloom toolchest by default."
+ elog "You may want to adjust your \$PATH, to enable "
+ elog "using the apps of heirloom toolchest by default."
elog "Man pages are installed in /usr/share/man/5man/"
elog "You may need to set \$MANPATH to access them."
}