summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-12-05 21:27:40 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-12-05 21:27:59 +0300
commit07b460372e50c050456f5575d1e2b60744811cee (patch)
tree3ce93a687c0f0e001e4c6e097028c1f96265d0ad /sys-apps/i2c-tools
parentsys-block/perccli: version bump to 7.5.007.0529 (diff)
downloadgentoo-07b460372e50c050456f5575d1e2b60744811cee.tar.gz
gentoo-07b460372e50c050456f5575d1e2b60744811cee.tar.bz2
gentoo-07b460372e50c050456f5575d1e2b60744811cee.zip
sys-apps/i2c-tools: Drop old
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/Manifest1
-rw-r--r--sys-apps/i2c-tools/files/i2c-tools-3.1.1-python-3.patch129
-rw-r--r--sys-apps/i2c-tools/i2c-tools-3.1.1-r1.ebuild62
3 files changed, 0 insertions, 192 deletions
diff --git a/sys-apps/i2c-tools/Manifest b/sys-apps/i2c-tools/Manifest
index 4c677a42f4fa..dd40b32bbdd1 100644
--- a/sys-apps/i2c-tools/Manifest
+++ b/sys-apps/i2c-tools/Manifest
@@ -1,3 +1,2 @@
-DIST i2c-tools-3.1.1.tar.bz2 71789 BLAKE2B 0a7a3db6a3b396cfb8d5e58d8c83cae4e52239786502c6552d971350f7fc05a1ce9d7d89e9cdb154a21ac15bdf34aa0dec9501ea45317ec9c5d9fc211780bbf1 SHA512 b91f89b803e5558d49ce63f42f6542438f4f47927e4ce420cd9df989cab14a5c55d971befed73e8f793b0cf4aa41936c0ef519e5a407dceb2c08964461e803c5
DIST i2c-tools-4.0.tar.xz 79972 BLAKE2B 982e4139ed0e2111f9e082d0690fcc0f86f97a433e292e9464b41991f14a1f90147a3612172bad6880f0df6896612e1dea0ae7bf6f459758b2cff45fb35a5dc7 SHA512 ddf86c357c101388193581bc40285089e6ab5e8d870f8aa5d594acc7ecb8596fbd30501e147b88bdea0200b1be88bc0a374356c188d1bcb067bf8e254e3dc51e
DIST i2c-tools-4.1.tar.xz 83576 BLAKE2B 0a9ed3bb335b61f6c17a6b6c705502ff008b4fb8bab6a5fde63163a32528b5214d92affc4b8d6cca29676dc7ba82dfa84be5f14943b7e81c8612a7d9419ac628 SHA512 83262bcfd94c2adf74517cc50095dd78221fa4d16a62397245d4a538de7463272abf4f6727024be8ab1ca8ecbfe647af85ba2a553e5b5e68a53e50dfcad20248
diff --git a/sys-apps/i2c-tools/files/i2c-tools-3.1.1-python-3.patch b/sys-apps/i2c-tools/files/i2c-tools-3.1.1-python-3.patch
deleted file mode 100644
index 1f3de76052e7..000000000000
--- a/sys-apps/i2c-tools/files/i2c-tools-3.1.1-python-3.patch
+++ /dev/null
@@ -1,129 +0,0 @@
-support python-3.x
-
-http://comments.gmane.org/gmane.linux.drivers.i2c/11290
-https://bugs.gentoo.org/492632
-
---- a/py-smbus/smbusmodule.c
-+++ b/py-smbus/smbusmodule.c
-@@ -32,15 +32,18 @@
- #define I2C_SMBUS_I2C_BLOCK_DATA 8
- #endif
-
--PyDoc_STRVAR(SMBus_module_doc,
-- "This module defines an object type that allows SMBus transactions\n"
-- "on hosts running the Linux kernel. The host kernel must have I2C\n"
-- "support, I2C device interface support, and a bus adapter driver.\n"
-- "All of these can be either built-in to the kernel, or loaded from\n"
-- "modules.\n"
-- "\n"
-- "Because the I2C device interface is opened R/W, users of this\n"
-- "module usually must have root permissions.\n");
-+#define module_doc \
-+ "This module defines an object type that allows SMBus transactions\n" \
-+ "on hosts running the Linux kernel. The host kernel must have I2C\n" \
-+ "support, I2C device interface support, and a bus adapter driver.\n" \
-+ "All of these can be either built-in to the kernel, or loaded from\n" \
-+ "modules.\n" \
-+ "\n" \
-+ "Because the I2C device interface is opened R/W, users of this\n" \
-+ "module usually must have root permissions.\n"
-+#if PY_MAJOR_VERSION <= 2
-+PyDoc_STRVAR(SMBus_module_doc, module_doc);
-+#endif
-
- typedef struct {
- PyObject_HEAD
-@@ -91,7 +94,11 @@ SMBus_dealloc(SMBus *self)
- PyObject *ref = SMBus_close(self);
- Py_XDECREF(ref);
-
-+#if PY_MAJOR_VERSION >= 3
-+ Py_TYPE(self)->tp_free((PyObject*)self);
-+#else
- self->ob_type->tp_free((PyObject *)self);
-+#endif
- }
-
- #define MAXPATH 16
-@@ -431,11 +438,19 @@ SMBus_list_to_data(PyObject *list, union i2c_smbus_data *data)
-
- for (ii = 0; ii < len; ii++) {
- PyObject *val = PyList_GET_ITEM(list, ii);
-+#if PY_MAJOR_VERSION >= 3
-+ if (!PyLong_Check(val)) {
-+#else
- if (!PyInt_Check(val)) {
-+#endif
- PyErr_SetString(PyExc_TypeError, msg);
- return 0; /* fail */
- }
-+#if PY_MAJOR_VERSION >= 3
-+ data->block[ii+1] = (__u8)PyLong_AS_LONG(val);
-+#else
- data->block[ii+1] = (__u8)PyInt_AS_LONG(val);
-+#endif
- }
-
- return 1; /* success */
-@@ -633,9 +648,27 @@ static PyGetSetDef SMBus_getset[] = {
- {NULL},
- };
-
-+#if PY_MAJOR_VERSION >= 3
-+static struct PyModuleDef SMBusModule = {
-+ PyModuleDef_HEAD_INIT,
-+ "smbus.SMBus", /* m_name */
-+ module_doc, /* m_doc */
-+ -1, /* m_size */
-+ NULL, /* m_methods */
-+ NULL, /* m_reload */
-+ NULL, /* m_traverse */
-+ NULL, /* m_clear */
-+ NULL, /* m_free */
-+};
-+#endif
-+
- static PyTypeObject SMBus_type = {
-+#if PY_MAJOR_VERSION >= 3
-+ PyVarObject_HEAD_INIT(NULL, 0)
-+#else
- PyObject_HEAD_INIT(NULL)
- 0, /* ob_size */
-+#endif
- "smbus.SMBus", /* tp_name */
- sizeof(SMBus), /* tp_basicsize */
- 0, /* tp_itemsize */
-@@ -683,16 +716,32 @@ static PyMethodDef SMBus_module_methods[] = {
- #define PyMODINIT_FUNC void
- #endif
- PyMODINIT_FUNC
--initsmbus(void)
-+#if PY_MAJOR_VERSION >= 3
-+PyInit_smbus(void)
-+#else
-+initsmbus(void)
-+#endif
- {
- PyObject* m;
-
-+#if PY_MAJOR_VERSION >= 3
-+ if (PyType_Ready(&SMBus_type) < 0)
-+ return NULL;
-+
-+ m = PyModule_Create(&SMBusModule);
-+ if (m == NULL)
-+ return NULL;
-+#else
- if (PyType_Ready(&SMBus_type) < 0)
- return;
-
- m = Py_InitModule3("smbus", SMBus_module_methods, SMBus_module_doc);
-+#endif
-
- Py_INCREF(&SMBus_type);
- PyModule_AddObject(m, "SMBus", (PyObject *)&SMBus_type);
-+#if PY_MAJOR_VERSION >= 3
-+ return m;
-+#endif
- }
-
diff --git a/sys-apps/i2c-tools/i2c-tools-3.1.1-r1.ebuild b/sys-apps/i2c-tools/i2c-tools-3.1.1-r1.ebuild
deleted file mode 100644
index 98c99d4b0435..000000000000
--- a/sys-apps/i2c-tools/i2c-tools-3.1.1-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-DISTUTILS_OPTIONAL="1"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
-HOMEPAGE="http://www.lm-sensors.org/wiki/I2CTools"
-SRC_URI="http://dl.lm-sensors.org/i2c-tools/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="!<sys-apps/lm_sensors-3
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- epatch "${FILESDIR}"/${PN}-3.1.1-python-3.patch #492632
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- use python && distutils-r1_src_configure
-}
-
-src_compile() {
- emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
- emake -C eepromer CC=$(tc-getCC) CFLAGS="${CFLAGS} -I../include"
- if use python ; then
- cd py-smbus || die
- append-cppflags -I../include
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- emake install prefix="${D}"/usr
- dosbin eepromer/eepro{g,m{,er}}
- rm -rf "${D}"/usr/include || die # part of linux-headers
- dodoc CHANGES README
- local d
- for d in eeprom eepromer ; do
- docinto ${d}
- dodoc ${d}/README*
- done
-
- if use python ; then
- cd py-smbus || die
- docinto py-smbus
- dodoc README*
- distutils-r1_src_install
- fi
-}