summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-11-27 10:35:55 +0100
committerJonas Stein <jstein@gentoo.org>2017-11-27 10:36:35 +0100
commit640c3a6edc32e21ffefc933bec1cd5eb003516e2 (patch)
treea419ad986629ca9c6099c3fe951c1c9e92b13313 /sys-apps/inxi/inxi-2.3.47.ebuild
parentprofiles: Fix package.use.mask comment for linkchecker[X] (diff)
downloadgentoo-640c3a6edc32e21ffefc933bec1cd5eb003516e2.tar.gz
gentoo-640c3a6edc32e21ffefc933bec1cd5eb003516e2.tar.bz2
gentoo-640c3a6edc32e21ffefc933bec1cd5eb003516e2.zip
sys-apps/inxi: Version bump to 2.3.47
Version bump to 2.3.47, which was released on 2017-11-26. Package-Manager: Portage-2.3.16, Repoman-2.3.5
Diffstat (limited to 'sys-apps/inxi/inxi-2.3.47.ebuild')
-rw-r--r--sys-apps/inxi/inxi-2.3.47.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-2.3.47.ebuild b/sys-apps/inxi/inxi-2.3.47.ebuild
new file mode 100644
index 000000000000..948a5917d27a
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.47.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT="0a9ac17c8ea0b0ab61ba0ad50b34c9a4765ed7a0"
+# ^^ because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin ${PN}
+ unpack ./${PN}.1.gz
+ doman ${PN}.1
+}