summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2018-01-17 04:33:51 +0100
committerJonas Stein <jstein@gentoo.org>2018-01-17 04:33:51 +0100
commit89bdc6ffd56d1571f91a247b4d1a63b2ac258876 (patch)
tree137f799c69fe05a18d900c2a9048590cdaa97a34 /sys-apps/inxi/inxi-2.3.55.ebuild
parentapp-emulation/ganeti: Allow arping from iputils as well as the separate package (diff)
downloadgentoo-89bdc6ffd56d1571f91a247b4d1a63b2ac258876.tar.gz
gentoo-89bdc6ffd56d1571f91a247b4d1a63b2ac258876.tar.bz2
gentoo-89bdc6ffd56d1571f91a247b4d1a63b2ac258876.zip
sys-apps/inxi: version bump to 2.3.55
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/inxi/inxi-2.3.55.ebuild')
-rw-r--r--sys-apps/inxi/inxi-2.3.55.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-2.3.55.ebuild b/sys-apps/inxi/inxi-2.3.55.ebuild
new file mode 100644
index 000000000000..428e0c646b33
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.55.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT="f31a6da7acb470813bec507da678d3054c5ff29d"
+# ^^ because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+DEPEND=""
+RDEPEND="sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin ${PN}
+ unpack ./${PN}.1.gz
+ doman ${PN}.1
+}