summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2022-06-12 14:41:46 +0200
committerJonas Stein <jstein@gentoo.org>2022-06-12 14:41:46 +0200
commit040ee6dcd7bb1b3b7aa640fa0cb1909cacf6c904 (patch)
tree9368e90fe4c843e7f4b381159182e6d75fedfc1f /sys-apps/inxi
parenttoolchain.eclass: add use-dep default for D (diff)
downloadgentoo-040ee6dcd7bb1b3b7aa640fa0cb1909cacf6c904.tar.gz
gentoo-040ee6dcd7bb1b3b7aa640fa0cb1909cacf6c904.tar.bz2
gentoo-040ee6dcd7bb1b3b7aa640fa0cb1909cacf6c904.zip
sys-apps/inxi: bump to 3.3.17.1
Version bump of inxi Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.17.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index bf99acc8f283..62e0cd64d678 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -4,3 +4,4 @@ DIST inxi-3.3.06.1.tar.gz 460416 BLAKE2B a7a5eeade861294c8c18cd9594ef6fd0c681d8a
DIST inxi-3.3.08.1.tar.gz 467132 BLAKE2B c0254174c0a48936e1f183c16f985838cf74302da706996c1baec0c67b9c4209da5b555805cb668d626eccaa69f95e3cab2605b06d2cc7361a6cd3ff5d88c29e SHA512 bcbb81dd022dbd525ed3811406997c6689f968de8a3b6e0988381d9d2a488617ef3bc966034f9baac8eebb412b8d2e612b7cece29d65bdcb20d8b8cdeca112e6
DIST inxi-3.3.12.1.tar.gz 495524 BLAKE2B 76b8600ea5bb5430a30bf3876ca80c1dbc8033449c3526c945d7457f3d9176d6299acf6d1a0b3e92c2f84e4b01ba70acbb326cfc9cd5b906e9e5a28550efa670 SHA512 5772b77a35342b6dee7211f31a35552794fddcdb01012e604c501707f1e3756791376b92e5c8f3d8c85493b83f2394d2e6f90f6e473225388975de2e174a2997
DIST inxi-3.3.13.1.tar.gz 524354 BLAKE2B de12d2145f61b385d636aa9aa1efa057cfa12b010789ec34602ee7567d4db34a960a85b47d17f7a4db8cdb68a44d1085ca2f3be11ca503e5172525d75901d244 SHA512 6eed08ed0efb3574d294127beaec1373df434554ad98debd25ac865b85ab98e81e11f0cee855da0213cbc25fee95ce8504c7eaee90d99b8ad7c63f2b301394f3
+DIST inxi-3.3.17.1.tar.gz 558476 BLAKE2B a53a90a9bbea44da7e2f4c77d2fbd6cf41fd4bcf95defe7c27379b62ccfbeee70e06865034082e4ffd24018312ca0f439d9ef7d746c979fbd4c5fff47b42f165 SHA512 2bf28e8c4bc3d93e309639e04dfafd6e7b2c82b33178c11e138828c8378e1636b1fb16dbae88838e69953020789637745ffa54818ed954624995c1daaf2387cb
diff --git a/sys-apps/inxi/inxi-3.3.17.1.ebuild b/sys-apps/inxi/inxi-3.3.17.1.ebuild
new file mode 100644
index 000000000000..49cc31d24326
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.17.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}