summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2023-12-21 20:14:15 +0100
committerJonas Stein <jstein@gentoo.org>2023-12-21 20:15:31 +0100
commit26d8dafbaea03ac1d0d7407071e1ed18177ac827 (patch)
treee8cda60c204d597d8563d73f4b5ac59d029d820b /sys-apps/inxi
parentmedia-libs/mesa: Add Python 3.12 compatibility (diff)
downloadgentoo-26d8dafbaea03ac1d0d7407071e1ed18177ac827.tar.gz
gentoo-26d8dafbaea03ac1d0d7407071e1ed18177ac827.tar.bz2
gentoo-26d8dafbaea03ac1d0d7407071e1ed18177ac827.zip
sys-apps/inxi: add 3.3.31.2
Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.31.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index 01945b33d244..38723e9e7be8 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -2,3 +2,4 @@ DIST inxi-3.3.27.1.tar.gz 614167 BLAKE2B 1a312255340bfe361eb10dd725cc9fb1421d8df
DIST inxi-3.3.28.1.tar.gz 624472 BLAKE2B 3d8ac9c21a7531e694e5de3a764906a69ef0c869f1bb4b7b5e5d0b42a74240a141c97401dfe78a85da27e7489d708fbfc4eb568adaab5270388aebd108f29e1a SHA512 6360193cc1f7a71c7329352311fac625e6c80e37c2bd783a78a534ec9712afd7df17b445c652d97415f6162512ede34b32958311b1c5086e899a2aded7a8efd9
DIST inxi-3.3.29.1.tar.gz 630296 BLAKE2B 176b20b113b3339f27d2ec16681d652e8ccaefed80c220078fa4e625ad7191cd6ebc9ada049197a858475e5c656b5f74f599ca202e1e47d6682e4cd9049eb763 SHA512 09b5a7553ccfd42a3c2e58d4718c487f84bf22df76710a6c42a2a4dd08343279f1d2523652a476ed475c5e019ad5aa02c0886bc40d57de407c9489054f812b5c
DIST inxi-3.3.30.1.tar.gz 643283 BLAKE2B cfcafc643e7e18261fac622df3614e7ad296ec2233ebf6750243d9490e0ca5e8ba3742286a0630ae948d16ac4d09705ffc1b20df666f48ed2c5331a8320919d7 SHA512 dba5c23d991bd6fb34eec9c2b6107da4e0ddab202f97e8aa53efb25d446fbe77f5250a9d14f543014f21d2cc614cd4e2d486a9f1fae78dde37ecee418cb763f5
+DIST inxi-3.3.31.2.tar.gz 646036 BLAKE2B 271a15f0ac88543b1950e1eeca99deb2991138cb73bfcd9db77a63e49ae71e6aa4fc1f7ad4c837485d42b1bc5e5a122a3ba50e61faaf7238590c135b5db496d4 SHA512 d45bcfcddcf4229a292ea95e8517308852a5ffec8f00a059a2191acbb5a7e0b4e298c8b0597b3281e600913d82ce3e7d284735e608032bd843ddb79ae030e3ae
diff --git a/sys-apps/inxi/inxi-3.3.31.2.ebuild b/sys-apps/inxi/inxi-3.3.31.2.ebuild
new file mode 100644
index 000000000000..1b3918e6aebe
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.31.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}