summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2023-08-09 23:55:09 +0200
committerJonas Stein <jstein@gentoo.org>2023-08-09 23:55:09 +0200
commit4af1e1383958d1de060028360a6745341f5a1ae0 (patch)
tree671eaf0ecb8feaacce86be3bdb48686452bce473 /sys-apps/inxi
parentapp-editors/ghostwriter: drop 2.1.6 (diff)
downloadgentoo-4af1e1383958d1de060028360a6745341f5a1ae0.tar.gz
gentoo-4af1e1383958d1de060028360a6745341f5a1ae0.tar.bz2
gentoo-4af1e1383958d1de060028360a6745341f5a1ae0.zip
sys-apps/inxi: add 3.3.28.1
Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.28.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index 2553fe38e431..16aa442cf3a7 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -1,3 +1,4 @@
DIST inxi-3.3.20.1.tar.gz 565689 BLAKE2B 0b89e54e22d0c88b57fdc2dcb08fc3cbe6b79a724c12d8eafd2e6eb6639ee1346ef9ee34b09f446464bafa35df87489ff9b40ad9e8de67fbe82c1becdd5af8bf SHA512 bdc4de6d2978ff17bdd4a5366d66fb483a304c61448ef33be902080a75ae6e78eba6bcd31b9a799a1eff01f22cc8e72200f314209e36af4287d8e5256bca4d05
DIST inxi-3.3.25.1.tar.gz 591556 BLAKE2B 5e9f24a7e9d8a2ef0322d18e106da1b126e7aed7ebb468aa7f7e553ce02dece9a255c1c155eefe7d766c501e8a80e48a5a3ac85fd4c12b07cf870076589cdb93 SHA512 1d2fc98c22ba3efb026e12dd17e2dcbe61a849a34846a72ee7ec267f3c233f2903606c3d17d79aacbd2a7c9842f39beb9e61933d41b7914ba07bdace3d29e53b
DIST inxi-3.3.27.1.tar.gz 614167 BLAKE2B 1a312255340bfe361eb10dd725cc9fb1421d8dfda34ee944347278e4a293cbcb51d1e2b7aa00f26c16286b90f26d3e0f91f68fb4beeb112ecd8f7a3bc86680ff SHA512 f21285d709d8dc7ce393a6c3b43b5ebabb8ef2c55adf43f00935b728a28f502bbcbd8c1482249e872e4623430f01b4e8cf51f0a6790d56fb12147fa125152575
+DIST inxi-3.3.28.1.tar.gz 624472 BLAKE2B 3d8ac9c21a7531e694e5de3a764906a69ef0c869f1bb4b7b5e5d0b42a74240a141c97401dfe78a85da27e7489d708fbfc4eb568adaab5270388aebd108f29e1a SHA512 6360193cc1f7a71c7329352311fac625e6c80e37c2bd783a78a534ec9712afd7df17b445c652d97415f6162512ede34b32958311b1c5086e899a2aded7a8efd9
diff --git a/sys-apps/inxi/inxi-3.3.28.1.ebuild b/sys-apps/inxi/inxi-3.3.28.1.ebuild
new file mode 100644
index 000000000000..1b3918e6aebe
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.28.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}