summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2023-05-20 15:08:37 +0200
committerJonas Stein <jstein@gentoo.org>2023-05-20 15:09:10 +0200
commitf43f9a485182ba8ec160ecd64ca6014493db6743 (patch)
tree3fc5d48c3215995ea949455b3f44d2bb1b96b741 /sys-apps/inxi
parentwww-client/elinks: Stabilize 0.16.1.1-r1 amd64, #906818 (diff)
downloadgentoo-f43f9a485182ba8ec160ecd64ca6014493db6743.tar.gz
gentoo-f43f9a485182ba8ec160ecd64ca6014493db6743.tar.bz2
gentoo-f43f9a485182ba8ec160ecd64ca6014493db6743.zip
sys-apps/inxi: add 3.3.27.1
Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.27.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index 570952846e6f..c343311bfe87 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -1,3 +1,4 @@
DIST inxi-3.3.17.1.tar.gz 558476 BLAKE2B a53a90a9bbea44da7e2f4c77d2fbd6cf41fd4bcf95defe7c27379b62ccfbeee70e06865034082e4ffd24018312ca0f439d9ef7d746c979fbd4c5fff47b42f165 SHA512 2bf28e8c4bc3d93e309639e04dfafd6e7b2c82b33178c11e138828c8378e1636b1fb16dbae88838e69953020789637745ffa54818ed954624995c1daaf2387cb
DIST inxi-3.3.20.1.tar.gz 565689 BLAKE2B 0b89e54e22d0c88b57fdc2dcb08fc3cbe6b79a724c12d8eafd2e6eb6639ee1346ef9ee34b09f446464bafa35df87489ff9b40ad9e8de67fbe82c1becdd5af8bf SHA512 bdc4de6d2978ff17bdd4a5366d66fb483a304c61448ef33be902080a75ae6e78eba6bcd31b9a799a1eff01f22cc8e72200f314209e36af4287d8e5256bca4d05
DIST inxi-3.3.25.1.tar.gz 591556 BLAKE2B 5e9f24a7e9d8a2ef0322d18e106da1b126e7aed7ebb468aa7f7e553ce02dece9a255c1c155eefe7d766c501e8a80e48a5a3ac85fd4c12b07cf870076589cdb93 SHA512 1d2fc98c22ba3efb026e12dd17e2dcbe61a849a34846a72ee7ec267f3c233f2903606c3d17d79aacbd2a7c9842f39beb9e61933d41b7914ba07bdace3d29e53b
+DIST inxi-3.3.27.1.tar.gz 614167 BLAKE2B 1a312255340bfe361eb10dd725cc9fb1421d8dfda34ee944347278e4a293cbcb51d1e2b7aa00f26c16286b90f26d3e0f91f68fb4beeb112ecd8f7a3bc86680ff SHA512 f21285d709d8dc7ce393a6c3b43b5ebabb8ef2c55adf43f00935b728a28f502bbcbd8c1482249e872e4623430f01b4e8cf51f0a6790d56fb12147fa125152575
diff --git a/sys-apps/inxi/inxi-3.3.27.1.ebuild b/sys-apps/inxi/inxi-3.3.27.1.ebuild
new file mode 100644
index 000000000000..1b3918e6aebe
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.27.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}