summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-24 18:20:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-24 18:20:29 +0200
commitc05e02feb110d51baa0b9ebd41d7945f128865cf (patch)
treefcfd6826b1a53caa029634002d92fbaddea1225f /sys-apps/ipmiutil
parentmedia-plugins/qmmp-plugin-pack: Bump to version 1.2.3 (diff)
downloadgentoo-c05e02feb110d51baa0b9ebd41d7945f128865cf.tar.gz
gentoo-c05e02feb110d51baa0b9ebd41d7945f128865cf.tar.bz2
gentoo-c05e02feb110d51baa0b9ebd41d7945f128865cf.zip
sys-apps/ipmiutil: Bump to version 3.1.3
Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'sys-apps/ipmiutil')
-rw-r--r--sys-apps/ipmiutil/Manifest1
-rw-r--r--sys-apps/ipmiutil/ipmiutil-3.1.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/ipmiutil/Manifest b/sys-apps/ipmiutil/Manifest
index aeca24af5547..641f178e88e2 100644
--- a/sys-apps/ipmiutil/Manifest
+++ b/sys-apps/ipmiutil/Manifest
@@ -2,3 +2,4 @@ DIST ipmiutil-3.0.6.tar.gz 1692679 BLAKE2B dcc02dbb5467b824005dbc95c8f5231b2e275
DIST ipmiutil-3.0.9.tar.gz 1697688 BLAKE2B 93ed8865cae1cea0ea4f7de4683f4698e3f75e9190cc7e0af1832ca44a08f52aa149393761f1ede3994827db78841061d54058bbe4178b5930accd3a4c225ba7 SHA512 c2c0a516216a46a52621159e665a77d96cf81f385fc9cf19877e72283be3e1a4dad5a4826454727b71576c22cc4de3c73ff428d26f35bf496c7dc1511305cda3
DIST ipmiutil-3.1.1.tar.gz 1697588 BLAKE2B 89d5f6a4b92494d5b5845a856011bf75eb6925506d7956b72efd3a258b29726f3b426185588cbf45a721c804e5e2f8203b1ba5ca132e8e907435cc2cbe5e563a SHA512 c2a7e05f85d668d6d02c990c1078d6f05c30f7ca26b5fdb4bbfe09952dcc4e9cc5eb67657ca07770fa8b0d333bc4d4a96ba845b45efe942c28342be013cf60bd
DIST ipmiutil-3.1.2.tar.gz 1698885 BLAKE2B aa6ad98b38c2d2c4a618717842afc88496f88c291a2731fe95072005a4a85f6dcb3a312924c3353e7b902d90a6bfbedc73bef0ce3d7c31d2326db14e4777ee0b SHA512 83dfddb30e8ddb8ac323473873e0920d2f81c059790556a472fb33c4dd140f5045b74f6f63e3300817b2f5c4af3d5ce35f3bacb96dc65c91ad0133bf088ba565
+DIST ipmiutil-3.1.3.tar.gz 1698835 BLAKE2B a540a4522a22f98ad47c89e59f371e5304583cfaab348154dee366a058d78ca6d6ecd6003d8b49c08e8247d38254f7abf48ee05672ddd678566d40a66f63c912 SHA512 bd1f95b59583a07a5b6001b40e59269f25eb63b69e33f7fad6dd40136e1ea7611e647eb5ed2e2a9746944bde2dc2a3aa2def44238947693d75d9ca48697e1b99
diff --git a/sys-apps/ipmiutil/ipmiutil-3.1.3.ebuild b/sys-apps/ipmiutil/ipmiutil-3.1.3.ebuild
new file mode 100644
index 000000000000..c3f0ddfbf05e
--- /dev/null
+++ b/sys-apps/ipmiutil/ipmiutil-3.1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools systemd
+
+DESCRIPTION="IPMI Management Utilities"
+HOMEPAGE="http://ipmiutil.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-1:0="
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.9.8-flags.patch
+ "${FILESDIR}"/${PN}-2.9.9-lib_symlink.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's|-O2 -g|$(CFLAGS)|g;s|-g -O2|$(CFLAGS)|g' util/Makefile.am* || die
+ sed -i -e 's|which rpm |which we_are_gentoo_rpm_is_a_guest |' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-systemd --enable-sha256
+}
+
+src_compile() {
+ # Ulgy workaround. Upstream is misusing the make system here
+ # and it doesn't even work.
+ # Please check on each bump if this workaround is still required.
+ pushd lib/lanplus &>/dev/null || die
+ emake || die "emake lanplus failed"
+ cp libipmi_lanplus.a .. || die
+ popd &>/dev/null || die
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysdto="${D}/$(systemd_get_systemunitdir)" install
+ dodoc -r AUTHORS ChangeLog NEWS README TODO doc/UserGuide
+
+ # Init scripts are only for Fedora
+ rm -r "${ED%/}"/etc/init.d || die 'remove initscripts failed'
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+
+ keepdir /var/lib/ipmiutil
+}