summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-11 11:30:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-11 11:30:52 +0200
commit6c754c994189dc259324c3b6aa8f0e8a1deb4464 (patch)
tree6ad07f86b41421591060f655e2fb71f1578bf771 /sys-apps/iproute2/iproute2-9999.ebuild
parentsys-apps/iproute2: Bump to version 5.1.0 (diff)
downloadgentoo-6c754c994189dc259324c3b6aa8f0e8a1deb4464.tar.gz
gentoo-6c754c994189dc259324c3b6aa8f0e8a1deb4464.tar.bz2
gentoo-6c754c994189dc259324c3b6aa8f0e8a1deb4464.zip
sys-apps/iproute2: Synced live ebuild
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/iproute2/iproute2-9999.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index d5befeb1ccff..8f2fdbfb7d99 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs flag-o-matic multilib
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="mirror://kernel/linux/utils/net/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
fi
DESCRIPTION="kernel routing and traffic control utilities"
@@ -32,11 +32,12 @@ RDEPEND="
atm? ( net-dialup/linux-atm )
selinux? ( sys-libs/libselinux )
"
-# We require newer linux-headers for ipset support #549948 and some defines #553876
DEPEND="
${RDEPEND}
+"
+# We require newer linux-headers for ipset support #549948 and some defines #553876
+BDEPEND="
app-arch/xz-utils
- iptables? ( virtual/pkgconfig )
>=sys-devel/bison-2.4
sys-devel/flex
>=sys-kernel/linux-headers-3.16
@@ -129,16 +130,16 @@ src_install() {
emake \
DESTDIR="${D}" \
- LIBDIR="${EPREFIX%/}"/$(get_libdir) \
- SBINDIR="${EPREFIX%/}"/sbin \
- CONFDIR="${EPREFIX%/}"/etc/iproute2 \
- DOCDIR="${EPREFIX%/}"/usr/share/doc/${PF} \
- MANDIR="${EPREFIX%/}"/usr/share/man \
- ARPDDIR="${EPREFIX%/}"/var/lib/arpd \
+ LIBDIR="${EPREFIX}"/$(get_libdir) \
+ SBINDIR="${EPREFIX}"/sbin \
+ CONFDIR="${EPREFIX}"/etc/iproute2 \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX}"/usr/share/man \
+ ARPDDIR="${EPREFIX}"/var/lib/arpd \
install
dodir /bin
- mv "${ED%/}"/{s,}bin/ip || die #330115
+ mv "${ED}"/{s,}bin/ip || die #330115
dolib.a lib/libnetlink.a
insinto /usr/include
@@ -146,12 +147,12 @@ src_install() {
# This local header pulls in a lot of linux headers it
# doesn't directly need. Delete this header that requires
# linux-headers-3.8 until that goes stable. #467716
- sed -i '/linux\/netconf.h/d' "${ED%/}"/usr/include/libnetlink.h || die
+ sed -i '/linux\/netconf.h/d' "${ED}"/usr/include/libnetlink.h || die
if use berkdb ; then
keepdir /var/lib/arpd
# bug 47482, arpd doesn't need to be in /sbin
dodir /usr/bin
- mv "${ED%/}"/sbin/arpd "${ED%/}"/usr/bin/ || die
+ mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
fi
}