summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-03-01 18:15:12 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-03-01 18:20:41 +0100
commit13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036 (patch)
tree3b867079094cd71bb770193ac7656985248edb73 /sys-apps/irqbalance/files
parentnet-dns/dnsmasq: add support dhcp_release6, needed for openstack ocata (diff)
downloadgentoo-13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036.tar.gz
gentoo-13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036.tar.bz2
gentoo-13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036.zip
sys-apps/irqbalance: Bump to version 1.2.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/irqbalance/files')
-rw-r--r--sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch32
-rw-r--r--sys-apps/irqbalance/files/irqbalance.init.420
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch b/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch
new file mode 100644
index 000000000000..20716542b6dd
--- /dev/null
+++ b/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch
@@ -0,0 +1,32 @@
+From 287d50594fe624bdb4400611d0dbecec6ff38a41 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Wed, 1 Mar 2017 17:11:42 +0100
+Subject: [PATCH] Prefer pkgconfig to check for ncursesw.
+
+That way we take possible separate tinfo lib into account.
+---
+ configure.ac | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 17b879a..77d8aa4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,7 +26,13 @@ AC_CHECK_FUNCS(getopt_long)
+ AC_CHECK_LIB(numa, numa_available)
+ AC_CHECK_LIB(m, floor)
+
+-AC_CHECK_LIB(curses, mvprintw)
++PKG_CHECK_MODULES([NCURSESW], [ncursesw], [has_ncursesw=yes], [AC_CHECK_LIB(curses, mvprintw)])
++AS_IF([test "x$has_ncursesw" = "xyes"], [
++ AC_SUBST([NCURSESW_CFLAGS])
++ AC_SUBST([NCURSESW_LIBS])
++ LIBS="$LIBS $NCURSESW_LIBS"
++ AC_SUBST([LIBS])
++])
+
+ AC_C_CONST
+ AC_C_INLINE
+--
+2.12.0
+
diff --git a/sys-apps/irqbalance/files/irqbalance.init.4 b/sys-apps/irqbalance/files/irqbalance.init.4
new file mode 100644
index 000000000000..1fb9eeb11f4a
--- /dev/null
+++ b/sys-apps/irqbalance/files/irqbalance.init.4
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+command="/usr/sbin/irqbalance"
+command_args="${IRQBALANCE_OPTS}"
+
+start_pre() {
+ if grep -q MSI /proc/interrupts 2>/dev/null && \
+ test -z "$(find /sys/devices -type d -name msi_irqs 2>/dev/null)"; then
+ eerror "MSI interrupts found in /proc/interrupts but none found in sysfs."
+ eerror "You need to update your kernel."
+ return 1
+ fi
+}