summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2015-10-13 21:33:03 +0200
committerMarc Joliet <marcec@gmx.de>2015-10-13 21:33:03 +0200
commit1041f3d1355b8d81f1f8d51a0321509e0be45e30 (patch)
treeed21102341448cf50d63f20bf470afe6d25e6910 /sys-apps/irqbalance
parentsys-apps/irqbalance: service unit: use --foreground (diff)
downloadgentoo-1041f3d1355b8d81f1f8d51a0321509e0be45e30.tar.gz
gentoo-1041f3d1355b8d81f1f8d51a0321509e0be45e30.tar.bz2
gentoo-1041f3d1355b8d81f1f8d51a0321509e0be45e30.zip
sys-apps/irqbalance: revbump for new service unit
Signed-off-by: Marc Joliet <marcec@gmx.de>
Diffstat (limited to 'sys-apps/irqbalance')
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild b/sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..4962d7b0a57f
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa selinux"
+
+CDEPEND="dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newinitd "${FILESDIR}"/irqbalance.init.3 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_newunit "${FILESDIR}"/irqbalance.service.1 irqbalance.service
+}