summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2020-07-13 17:47:00 +1000
committerSam Jorna <wraeth@gentoo.org>2020-07-13 17:47:29 +1000
commitd463313263b988a4a8877765ee337bc7a6a4695b (patch)
treec0f476f9797fb9643ce4e31889f10aacaed0502b /sys-apps/kcheck/kcheck-9999.ebuild
parentsys-apps/kcheck: add py3.7 py3.8, fix deps, EAPI7 (diff)
downloadgentoo-d463313263b988a4a8877765ee337bc7a6a4695b.tar.gz
gentoo-d463313263b988a4a8877765ee337bc7a6a4695b.tar.bz2
gentoo-d463313263b988a4a8877765ee337bc7a6a4695b.zip
sys-apps/kcheck: update live ebuild
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'sys-apps/kcheck/kcheck-9999.ebuild')
-rw-r--r--sys-apps/kcheck/kcheck-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/sys-apps/kcheck/kcheck-9999.ebuild b/sys-apps/kcheck/kcheck-9999.ebuild
index 2d83fb1a653b..d28b7022b350 100644
--- a/sys-apps/kcheck/kcheck-9999.ebuild
+++ b/sys-apps/kcheck/kcheck-9999.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,11 +21,13 @@ HOMEPAGE="https://github.com/wraeth/kcheck"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/configargparse[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]"
src_install() {
distutils-r1_src_install
- mkdir "${D}"etc || die
- mv -v "${D}"{usr/,}etc/kcheck.conf || die
+ mkdir "${D}"/etc || die
+ mv -v "${D}"/{usr/,}etc/kcheck.conf || die
+ rmdir -v "${D}"/usr/etc || die
}