summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-24 17:24:44 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-24 17:39:33 -0400
commit292b70740c3eb4516bf99a2cc2d12657a031ab00 (patch)
treecfef28fe459bdadab2d8973137874968da2c12c2 /sys-apps/kexec-tools/kexec-tools-2.0.12.ebuild
parentsys-apps/kexec-tools: drop some old versions (diff)
downloadgentoo-292b70740c3eb4516bf99a2cc2d12657a031ab00.tar.gz
gentoo-292b70740c3eb4516bf99a2cc2d12657a031ab00.tar.bz2
gentoo-292b70740c3eb4516bf99a2cc2d12657a031ab00.zip
sys-apps/kexec-tools: version bump to 2.0.12 #578164
Rework the init script heavily in the process to make it a bit less "smart" and respect user settings. #577496
Diffstat (limited to 'sys-apps/kexec-tools/kexec-tools-2.0.12.ebuild')
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.12.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.12.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.12.ebuild
new file mode 100644
index 000000000000..2a2d1600e837
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
+ AUTOTOOLS_AUTORECONF=true
+else
+ SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools-utils linux-info systemd
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="booke lzma xen zlib"
+
+REQUIRED_USE="lzma? ( zlib )"
+
+DEPEND="
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KEXEC"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
+ "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
+)
+
+pkg_setup() {
+ # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
+ export ASFLAGS="${CCASFLAGS}"
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with booke)
+ $(use_with lzma)
+ $(use_with xen)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ newinitd "${FILESDIR}"/kexec.init-2.0.12 kexec
+ newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
+
+ insinto /etc
+ doins "${FILESDIR}"/kexec.conf
+
+ insinto /etc/kernel/postinst.d
+ doins "${FILESDIR}"/90_kexec
+
+ systemd_dounit "${FILESDIR}"/kexec.service
+}
+
+pkg_postinst() {
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "For systemd support the new config file is"
+ elog " /etc/kexec.conf"
+ elog "Please adopt it to your needs as there is no autoconfig anymore"
+ fi
+}