summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-01-19 10:48:31 -0600
committerMike Frysinger <vapier@gentoo.org>2017-01-19 10:51:27 -0600
commit547bf7fbf276a24d17cfa2a21248cf7670e939f9 (patch)
tree0f4498e49ec36bf7e5e4606391959ba3fcdcca12 /sys-apps/keyutils
parentmedia-gfx/kphotoalbum: Remove 5.0.1 (diff)
downloadgentoo-547bf7fbf276a24d17cfa2a21248cf7670e939f9.tar.gz
gentoo-547bf7fbf276a24d17cfa2a21248cf7670e939f9.tar.bz2
gentoo-547bf7fbf276a24d17cfa2a21248cf7670e939f9.zip
sys-apps/keyutils: add upstream fix for tests endian checking #426424
Diffstat (limited to 'sys-apps/keyutils')
-rw-r--r--sys-apps/keyutils/files/keyutils-1.5.9-endian-check-1.patch43
-rw-r--r--sys-apps/keyutils/files/keyutils-1.5.9-endian-check-2.patch38
-rw-r--r--sys-apps/keyutils/keyutils-1.5.9-r2.ebuild1
3 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/keyutils/files/keyutils-1.5.9-endian-check-1.patch b/sys-apps/keyutils/files/keyutils-1.5.9-endian-check-1.patch
new file mode 100644
index 000000000000..18344b94940e
--- /dev/null
+++ b/sys-apps/keyutils/files/keyutils-1.5.9-endian-check-1.patch
@@ -0,0 +1,43 @@
+patch from upstream
+
+https://bugs.gentoo.org/426424
+
+From f0d9a8c15f1525d0404077f32fddccb606a61bac Mon Sep 17 00:00:00 2001
+From: Tyler Hicks <tyhicks@canonical.com>
+Date: Mon, 24 Feb 2014 18:52:41 -0600
+Subject: [PATCH] TEST: Make endianness detection work with file 5.14
+
+The 5.14 release of file outputs an extra space after [LM]SB:
+
+$ ./src/file -m magic/magic.mgc -L /proc/$$/exe
+/proc/12755/exe: ELF 64-bit LSB executable, ...
+
+This was due to the elf magic file containing some trailing spaces in
+the 5.14 release.
+
+Signed-off-by: Tyler Hicks <tyhicks@canonical.com>
+Signed-off-by: David Howells <dhowells@redhat.com>
+---
+ tests/toolbox.inc.sh | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/toolbox.inc.sh b/tests/toolbox.inc.sh
+index cbc49e0fce23..fe3c7f71299a 100644
+--- a/tests/toolbox.inc.sh
++++ b/tests/toolbox.inc.sh
+@@ -17,10 +17,10 @@ includes=${includes%/*}/
+ echo === $OUTPUTFILE ===
+
+ endian=`file -L /proc/$$/exe`
+-if expr "$endian" : '.* MSB executable.*' >&/dev/null
++if expr "$endian" : '.* MSB \+executable.*' >&/dev/null
+ then
+ endian=BE
+-elif expr "$endian" : '.* LSB executable.*' >&/dev/null
++elif expr "$endian" : '.* LSB \+executable.*' >&/dev/null
+ then
+ endian=LE
+ else
+--
+2.11.0
+
diff --git a/sys-apps/keyutils/files/keyutils-1.5.9-endian-check-2.patch b/sys-apps/keyutils/files/keyutils-1.5.9-endian-check-2.patch
new file mode 100644
index 000000000000..a4558d8edfcb
--- /dev/null
+++ b/sys-apps/keyutils/files/keyutils-1.5.9-endian-check-2.patch
@@ -0,0 +1,38 @@
+patch from upstream
+
+https://bugs.gentoo.org/426424
+
+From ce92e974b8ecff19cf430b7b58a09b8190645b5c Mon Sep 17 00:00:00 2001
+From: David Howells <dhowells@redhat.com>
+Date: Fri, 26 Feb 2016 10:07:00 +0000
+Subject: [PATCH] TEST: Fix endianness determination
+
+Endianness determination was broken sometime after Fedora 20 when
+executables switched to being DYN objects rather than EXEC objects. This
+caused the output of file to change.
+
+Signed-off-by: David Howells <dhowells@redhat.com>
+---
+ tests/toolbox.inc.sh | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/toolbox.inc.sh b/tests/toolbox.inc.sh
+index f2463c57b40e..5ac23ffc04fb 100644
+--- a/tests/toolbox.inc.sh
++++ b/tests/toolbox.inc.sh
+@@ -13,10 +13,10 @@
+ echo === $OUTPUTFILE ===
+
+ endian=`file -L /proc/$$/exe`
+-if expr "$endian" : '.* MSB \+executable.*' >&/dev/null
++if expr "$endian" : '.* MSB \+\(executable\|shared object).*' >&/dev/null
+ then
+ endian=BE
+-elif expr "$endian" : '.* LSB \+executable.*' >&/dev/null
++elif expr "$endian" : '.* LSB \+\(executable\|shared object\).*' >&/dev/null
+ then
+ endian=LE
+ else
+--
+2.11.0
+
diff --git a/sys-apps/keyutils/keyutils-1.5.9-r2.ebuild b/sys-apps/keyutils/keyutils-1.5.9-r2.ebuild
index 0a46055b3f20..572489eb7692 100644
--- a/sys-apps/keyutils/keyutils-1.5.9-r2.ebuild
+++ b/sys-apps/keyutils/keyutils-1.5.9-r2.ebuild
@@ -27,6 +27,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.5-makefile-fixup.patch
+ epatch "${FILESDIR}"/${PN}-1.5.9-endian-check-{1,2}.patch #426424
# The lsb check is useless, so avoid spurious command not found messages.
sed -i -e 's,lsb_release,:,' tests/prepare.inc.sh || die