summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-09 09:43:49 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-09 09:43:49 +0100
commit30f0bdf1d1c8422d31d8a5c68ee6d40568289d63 (patch)
treeab322080114acc5a59d48d0088c61d4c199812f8 /sys-apps/kmod/kmod-9999.ebuild
parentsys-apps/kmod: Bump to version 25 (diff)
downloadgentoo-30f0bdf1d1c8422d31d8a5c68ee6d40568289d63.tar.gz
gentoo-30f0bdf1d1c8422d31d8a5c68ee6d40568289d63.tar.bz2
gentoo-30f0bdf1d1c8422d31d8a5c68ee6d40568289d63.zip
sys-apps/kmod: Synced live ebuild.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/kmod/kmod-9999.ebuild')
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index 3a82094b0518..1ffba7ee85cc 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit bash-completion-r1 eutils multilib python-r1
+inherit bash-completion-r1 ltprune multilib python-r1
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
- inherit autotools git-2
+ inherit autotools git-r3
else
SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -55,6 +55,8 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DOCS="NEWS README TODO"
src_prepare() {
+ default
+
if [ ! -e configure ]; then
if use doc; then
gtkdocize --copy --docdir libkmod/docs || die
@@ -75,15 +77,15 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}/bin"
- --with-rootlibdir="${EPREFIX}/$(get_libdir)"
--enable-shared
- $(use_enable static-libs static)
- $(use_enable tools)
+ --with-bashcompletiondir="$(get_bashcompdir)"
+ --with-rootlibdir="${EPREFIX}/$(get_libdir)"
$(use_enable debug)
$(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
+ $(use_enable tools)
$(use_with lzma xz)
$(use_with zlib)
- --with-bashcompletiondir="$(get_bashcompdir)"
)
local ECONF_SOURCE="${S}"