summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-03 18:44:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-03 18:45:06 +0100
commit1cc5d7c674a6fece0e3d20f5824039a506ccb9e8 (patch)
tree5110cf2af913c0358a7063a20e4c17e216564b82 /sys-apps/less/less-541.ebuild
parentnet-im/mcabber: amd64 stable wrt bug #669830 (diff)
downloadgentoo-1cc5d7c674a6fece0e3d20f5824039a506ccb9e8.tar.gz
gentoo-1cc5d7c674a6fece0e3d20f5824039a506ccb9e8.tar.bz2
gentoo-1cc5d7c674a6fece0e3d20f5824039a506ccb9e8.zip
sys-apps/less: Bump to version 541
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-apps/less/less-541.ebuild')
-rw-r--r--sys-apps/less/less-541.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/less/less-541.ebuild b/sys-apps/less/less-541.ebuild
new file mode 100644
index 000000000000..3bc3bf389320
--- /dev/null
+++ b/sys-apps/less/less-541.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre2 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre2 posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}