summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-09-24 12:31:25 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-09-24 12:31:25 -0700
commitab794e8557245ff87f998795a57ac7185dd68ef8 (patch)
tree4d94c2badbdc792cf24b2f05b7bc46c7aa074470 /sys-apps/linux-misc-apps
parentsys-apps/linux-misc-apps: bump for EAPI7 (diff)
downloadgentoo-ab794e8557245ff87f998795a57ac7185dd68ef8.tar.gz
gentoo-ab794e8557245ff87f998795a57ac7185dd68ef8.tar.bz2
gentoo-ab794e8557245ff87f998795a57ac7185dd68ef8.zip
sys-apps/linux-misc-apps: cleanup
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-apps/linux-misc-apps')
-rw-r--r--sys-apps/linux-misc-apps/files/hpfall.confd6
-rw-r--r--sys-apps/linux-misc-apps/files/hpfall.initd44
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-3.18.ebuild172
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-3.6-r2.ebuild184
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-4.19.ebuild216
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-4.4-r1.ebuild216
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-4.4.ebuild183
7 files changed, 0 insertions, 1021 deletions
diff --git a/sys-apps/linux-misc-apps/files/hpfall.confd b/sys-apps/linux-misc-apps/files/hpfall.confd
deleted file mode 100644
index 4f3451b0bff6..000000000000
--- a/sys-apps/linux-misc-apps/files/hpfall.confd
+++ /dev/null
@@ -1,6 +0,0 @@
-# /etc/conf.d/hpfall
-
-# The name of the disk device that hpfall should protect.
-# Usually this is 'sda' or 'hda' the primary master.
-
-DISK="sda" \ No newline at end of file
diff --git a/sys-apps/linux-misc-apps/files/hpfall.initd b/sys-apps/linux-misc-apps/files/hpfall.initd
deleted file mode 100644
index 8b4930612c4d..000000000000
--- a/sys-apps/linux-misc-apps/files/hpfall.initd
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-checkconfig() {
- if [ -z "$DISK" ] ; then
- eerror "You need to setup DISK in /etc/conf.d/hpfall first"
- return 1
- fi
-
- if [ ! -b /dev/${DISK} ]; then
- eerror "Could not find disk /dev/${DISK}!"
- eerror "Adjust the DISK setting in /etc/conf.d/hpfall"
- return 1
- fi
-
- if [ ! -e /sys/block/${DISK}/device/unload_heads ] ; then
- eerror "No protect entry for ${DISK}!"
- eerror "Kernel 2.6.28 and above is required"
- return 1
- fi
-
- if [ ! -c /dev/freefall ]; then
- ebegin "Loading hp_accel module"
- modprobe hp_accel
- eend $? || return 1
- fi
-}
-
-start () {
- checkconfig || return 1
-
- ebegin "Starting active hard-drive protection daemon"
- start-stop-daemon --start --quiet \
- --exec /usr/sbin/hpfall /dev/${DISK}
- eend $?
-}
-
-stop() {
- ebegin "Stopping active hard-drive protection daemon"
- start-stop-daemon --stop --quiet \
- --exec /usr/sbin/hpfall
- eend $?
-}
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-3.18.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-3.18.ebuild
deleted file mode 100644
index 4821b1c04c42..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-3.18.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator eutils toolchain-funcs linux-info ltprune flag-o-matic
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="https://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static-libs tcpd"
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v3.x/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.xz
-SRC_URI="${SRC_URI} https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_SOURCES}"
-
-# pmtools also provides turbostat
-# usbip available in seperate package now
-RDEPEND="sys-apps/hwids
- >=dev-libs/glib-2.6
- tcpd? ( sys-apps/tcp-wrappers )
- !sys-power/pmtools"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- Documentation/accounting/getdelays.c
- Documentation/laptops/dslm.c
- Documentation/laptops/freefall.c
- Documentation/networking/timestamping/timestamping.c
- Documentation/watchdog/src/watchdog-simple.c
- tools/cgroup/cgroup_event_listener.c
- tools/lguest/lguest.c
- tools/vm/slabinfo.c
- usr/gen_init_cpio.c
-)
-# tools/vm/page-types.c - broken, header path issue
-# tools/hv/hv_kvp_daemon.c - broken in 3.7 by missing linux/hyperv.h userspace
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- Documentation/misc-devices/mei:mei-amt-version
- tools/firewire:nosy-dump
- tools/power/x86/turbostat:turbostat:../../../../turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
-
- sed -i \
- -e '/^nosy-dump.*LDFLAGS/d' \
- -e '/^nosy-dump.*CFLAGS/d' \
- -e '/^nosy-dump.*CPPFLAGS/s,CPPFLAGS =,CPPFLAGS +=,g' \
- "${S}"/tools/firewire/Makefile
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch}
- #emake prepare modules_prepare ARCH=${karch}
- #touch Module.symvers
-
- # Now we can start building
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Building $dir => $binfile (via emake $target)"
- emake -C $dir ARCH=${karch} $target
- done
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Installing $s => $bin"
- dosbin ${dir}/${bin}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Installing $dir => $binfile"
- dosbin ${dir}/${binfile}
- done
-
- newconfd "${FILESDIR}"/freefall.confd freefall
- newinitd "${FILESDIR}"/freefall.initd freefall
- prune_libtool_files
-}
-
-pkg_postinst() {
- echo
- elog "The cpupower utility is maintained separately at sys-power/cpupower"
- elog "The usbip utility is maintained separately at net-misc/usbip"
- elog "The hpfall tool has been renamed by upstream to freefall; update your config if needed"
- if find /etc/runlevels/ -name hpfall ; then
- ewarn "You must change hpfall to freefall in your runlevels!"
- fi
-}
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-3.6-r2.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-3.6-r2.ebuild
deleted file mode 100644
index 4d1f8227e84b..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-3.6-r2.ebuild
+++ /dev/null
@@ -1,184 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator eutils toolchain-funcs linux-info ltprune autotools flag-o-matic
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="https://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static-libs tcpd"
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.bz2
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.bz2
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.bz2
-SRC_URI="${SRC_URI} https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
-
-# pmtools also provides turbostat
-# sysfsutils and glib for usbip - remove sysfsutils in 3.7 or 3.8
-RDEPEND="sys-apps/hwids
- >=sys-fs/sysfsutils-2
- >=dev-libs/glib-2.6
- tcpd? ( sys-apps/tcp-wrappers )
- !sys-power/pmtools
- !net-misc/usbip"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- Documentation/accounting/getdelays.c
- Documentation/cgroups/cgroup_event_listener.c
- Documentation/laptops/dslm.c
- Documentation/laptops/hpfall.c
- Documentation/networking/timestamping/timestamping.c
- Documentation/watchdog/src/watchdog-simple.c
- tools/lguest/lguest.c
- tools/vm/page-types.c
- tools/vm/slabinfo.c
- usr/gen_init_cpio.c
-)
-# tools/hv/hv_kvp_daemon.c - broken in 3.7 by missing linux/hyperv.h userspace
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- tools/firewire:nosy-dump
- tools/power/x86/turbostat:turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
- Documentation/misc-devices/mei:mei-amt-version
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
-
- pushd drivers/staging/usbip/userspace >/dev/null &&
- eautoreconf -i -f -v &&
- popd >/dev/null || die "usbip"
-
- sed -i \
- -e '/^nosy-dump.*LDFLAGS/d' \
- -e '/^nosy-dump.*CFLAGS/d' \
- -e '/^nosy-dump.*CPPFLAGS/s,CPPFLAGS =,CPPFLAGS +=,g' \
- "${S}"/tools/firewire/Makefile
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_configure() {
- cd drivers/staging/usbip/userspace && \
- econf \
- $(use_enable static-libs static) \
- $(use tcpd || echo --without-tcp-wrappers) \
- --with-usbids-dir=/usr/share/misc
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch}
- #emake prepare modules_prepare ARCH=${karch}
- #touch Module.symvers
-
- # Now we can start building
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target=${t/*:}
- einfo "Building $dir => $target"
- emake -C $dir ARCH=${karch} $target
- done
-
- emake -C drivers/staging/usbip/userspace
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Installing $s => $bin"
- dosbin ${dir}/${bin}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target=${t/*:}
- einfo "Installing $dir => $target"
- dosbin ${dir}/${target}
- done
-
- pushd drivers/staging/usbip/userspace >/dev/null \
- || die "Missing usbip/userspace"
- emake DESTDIR="${D}" install
-
- newdoc README README.usbip
- newdoc AUTHORS AUTHORS.usbip
- dodoc ../usbip_protocol.txt
- popd >/dev/null
-
- newconfd "${FILESDIR}"/hpfall.confd hpfall
- newinitd "${FILESDIR}"/hpfall.initd hpfall
- prune_libtool_files
-}
-
-pkg_postinst() {
- echo
- elog "The cpupower utility is maintained separately at sys-power/cpupower"
-}
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-4.19.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-4.19.ebuild
deleted file mode 100644
index 45c7b3fd3bb5..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-4.19.ebuild
+++ /dev/null
@@ -1,216 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator eutils toolchain-funcs linux-info ltprune autotools flag-o-matic
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="https://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static-libs tcpd usbip"
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v3.x/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.xz
-SRC_URI="${SRC_URI} https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_SOURCES}"
-
-# pmtools also provides turbostat
-# usbip available in seperate package now
-RDEPEND="sys-apps/hwids
- >=dev-libs/glib-2.6
- >=sys-kernel/linux-headers-$(get_version_component_range 1-2)
- usbip? (
- !net-misc/usbip
- tcpd? ( sys-apps/tcp-wrappers )
- virtual/libudev
- )
- !sys-power/pmtools"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- samples/watchdog/watchdog-simple.c
- tools/accounting/getdelays.c
- tools/cgroup/cgroup_event_listener.c
- tools/laptop/freefall/freefall.c
- tools/testing/selftests/networking/timestamping/timestamping.c
- tools/vm/slabinfo.c
- usr/gen_init_cpio.c
- # Broken:
- #tools/lguest/lguest.c # fails to compile
- #tools/vm/page-types.c # page-types.c:(.text+0xe2b): undefined reference to `debugfs__mount', not defined anywhere
- #tools/net/bpf_jit_disasm.c # /usr/include/x86_64-pc-linux-gnu/bfd.h:35:2: error: #error config.h must be included before this header
-)
-# tools/vm/page-types.c - broken, header path issue
-# tools/hv/hv_kvp_daemon.c - broken in 3.7 by missing linux/hyperv.h userspace
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- samples/mei:mei-amt-version
- tools/firewire:nosy-dump
- tools/iio:iio_event_monitor
- tools/iio:iio_generic_buffer
- tools/iio:lsiio
- tools/laptop/dslm:dslm
- tools/power/x86/turbostat:turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
- tools/thermal/tmon:tmon
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
-
- pushd tools/usb/usbip/ >/dev/null &&
- sed -i 's/-Werror[^ ]* //g' configure.ac &&
- eautoreconf -i -f -v &&
- popd >/dev/null || die "usbip"
-
- sed -i \
- -e '/^nosy-dump.*LDFLAGS/d' \
- -e '/^nosy-dump.*CFLAGS/d' \
- -e '/^nosy-dump.*CPPFLAGS/s,CPPFLAGS =,CPPFLAGS +=,g' \
- "${S}"/tools/firewire/Makefile
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_configure() {
- if use usbip; then
- pushd tools/usb/usbip/ || die
- econf \
- $(use_enable static-libs static) \
- $(use tcpd || echo --without-tcp-wrappers) \
- --with-usbids-dir=/usr/share/misc
- popd
- fi
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch}
- #emake prepare modules_prepare ARCH=${karch}
- #touch Module.symvers
-
- # Now we can start building
- append-cflags -I./tools/lib
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Building $dir => $binfile (via emake $target)"
- emake -C $dir ARCH=${karch} $target
- done
-
- if use usbip; then
- emake -C tools/usb/usbip
- fi
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Installing $s => $bin"
- dosbin ${dir}/${bin}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Installing $dir => $binfile"
- dosbin ${dir}/${binfile}
- done
-
- if use usbip; then
- pushd tools/usb/usbip/ >/dev/null || die "usbip"
- emake DESTDIR="${D}" install
- newdoc README README.usbip
- newdoc AUTHORS AUTHORS.usbip
- popd >/dev/null
- dodoc Documentation/usb/usbip_protocol.txt
- fi
-
- mv -f "${D}"/usr/sbin/{,iio_}generic_buffer
-
- newconfd "${FILESDIR}"/freefall.confd freefall
- newinitd "${FILESDIR}"/freefall.initd freefall
- prune_libtool_files
-}
-
-pkg_postinst() {
- echo
- elog "The cpupower utility is maintained separately at sys-power/cpupower"
- elog "The lguest utility no longer builds, and has been dropped."
- elog "The hpfall tool has been renamed by upstream to freefall; update your config if needed"
- if find /etc/runlevels/ -name hpfall ; then
- ewarn "You must change hpfall to freefall in your runlevels!"
- fi
- if use usbip; then
- elog "For using USB/IP you need to enable USBIP_VHCI_HCD in the client"
- elog "machine's kernel config and USBIP_HOST on the server."
- fi
-}
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-4.4-r1.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-4.4-r1.ebuild
deleted file mode 100644
index c1ed756f4430..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-4.4-r1.ebuild
+++ /dev/null
@@ -1,216 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator eutils toolchain-funcs linux-info ltprune autotools flag-o-matic
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="https://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static-libs tcpd usbip"
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v3.x/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.xz
-SRC_URI="${SRC_URI} https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_SOURCES}"
-
-# pmtools also provides turbostat
-# usbip available in seperate package now
-RDEPEND="sys-apps/hwids
- >=dev-libs/glib-2.6
- >=sys-kernel/linux-headers-$(get_version_component_range 1-2)
- usbip? (
- !net-misc/usbip
- tcpd? ( sys-apps/tcp-wrappers )
- virtual/libudev
- )
- !sys-power/pmtools"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- Documentation/accounting/getdelays.c
- Documentation/laptops/dslm.c
- Documentation/networking/timestamping/timestamping.c
- Documentation/watchdog/src/watchdog-simple.c
- tools/cgroup/cgroup_event_listener.c
- tools/laptop/freefall/freefall.c
- tools/vm/slabinfo.c
- usr/gen_init_cpio.c
- # Broken:
- #tools/lguest/lguest.c # fails to compile
- #tools/vm/page-types.c # page-types.c:(.text+0xe2b): undefined reference to `debugfs__mount', not defined anywhere
- #tools/net/bpf_jit_disasm.c # /usr/include/x86_64-pc-linux-gnu/bfd.h:35:2: error: #error config.h must be included before this header
-)
-# tools/vm/page-types.c - broken, header path issue
-# tools/hv/hv_kvp_daemon.c - broken in 3.7 by missing linux/hyperv.h userspace
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- Documentation/misc-devices/mei:mei-amt-version
- tools/firewire:nosy-dump
- tools/iio:generic_buffer
- tools/iio:iio_event_monitor
- tools/iio:lsiio
- tools/power/x86/turbostat:turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
- tools/thermal/tmon:tmon
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
-
- pushd tools/usb/usbip/ >/dev/null &&
- sed -i 's/-Werror[^ ]* //g' configure.ac &&
- eautoreconf -i -f -v &&
- popd >/dev/null || die "usbip"
-
- sed -i \
- -e '/^nosy-dump.*LDFLAGS/d' \
- -e '/^nosy-dump.*CFLAGS/d' \
- -e '/^nosy-dump.*CPPFLAGS/s,CPPFLAGS =,CPPFLAGS +=,g' \
- "${S}"/tools/firewire/Makefile
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_configure() {
- if use usbip; then
- pushd tools/usb/usbip/ || die
- econf \
- $(use_enable static-libs static) \
- $(use tcpd || echo --without-tcp-wrappers) \
- --with-usbids-dir=/usr/share/misc
- popd
- fi
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch}
- #emake prepare modules_prepare ARCH=${karch}
- #touch Module.symvers
-
- # Now we can start building
- append-cflags -I./tools/lib
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Building $dir => $binfile (via emake $target)"
- emake -C $dir ARCH=${karch} $target
- done
-
- if use usbip; then
- emake -C tools/usb/usbip
- fi
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Installing $s => $bin"
- dosbin ${dir}/${bin}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Installing $dir => $binfile"
- dosbin ${dir}/${binfile}
- done
-
- if use usbip; then
- pushd tools/usb/usbip/ >/dev/null || die "usbip"
- emake DESTDIR="${D}" install
- newdoc README README.usbip
- newdoc AUTHORS AUTHORS.usbip
- popd >/dev/null
- dodoc drivers/usb/usbip/usbip_protocol.txt
- fi
-
- mv -f "${D}"/usr/sbin/{,iio_}generic_buffer
-
- newconfd "${FILESDIR}"/freefall.confd freefall
- newinitd "${FILESDIR}"/freefall.initd freefall
- prune_libtool_files
-}
-
-pkg_postinst() {
- echo
- elog "The cpupower utility is maintained separately at sys-power/cpupower"
- elog "The lguest utility no longer builds, and has been dropped."
- elog "The hpfall tool has been renamed by upstream to freefall; update your config if needed"
- if find /etc/runlevels/ -name hpfall ; then
- ewarn "You must change hpfall to freefall in your runlevels!"
- fi
- if use usbip; then
- elog "For using USB/IP you need to enable USBIP_VHCI_HCD in the client"
- elog "machine's kernel config and USBIP_HOST on the server."
- fi
-}
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-4.4.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-4.4.ebuild
deleted file mode 100644
index ad1f27593bf9..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-4.4.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator eutils toolchain-funcs linux-info ltprune flag-o-matic
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="https://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static-libs tcpd"
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v3.x/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.xz
-SRC_URI="${SRC_URI} https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_SOURCES}"
-
-# pmtools also provides turbostat
-# usbip available in seperate package now
-RDEPEND="sys-apps/hwids
- >=dev-libs/glib-2.6
- tcpd? ( sys-apps/tcp-wrappers )
- !sys-power/pmtools"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- Documentation/accounting/getdelays.c
- Documentation/laptops/dslm.c
- Documentation/networking/timestamping/timestamping.c
- Documentation/watchdog/src/watchdog-simple.c
- tools/cgroup/cgroup_event_listener.c
- tools/laptop/freefall/freefall.c
- tools/vm/slabinfo.c
- usr/gen_init_cpio.c
- # Broken:
- #tools/lguest/lguest.c # fails to compile
- #tools/vm/page-types.c # page-types.c:(.text+0xe2b): undefined reference to `debugfs__mount', not defined anywhere
- #tools/net/bpf_jit_disasm.c # /usr/include/x86_64-pc-linux-gnu/bfd.h:35:2: error: #error config.h must be included before this header
-)
-# tools/vm/page-types.c - broken, header path issue
-# tools/hv/hv_kvp_daemon.c - broken in 3.7 by missing linux/hyperv.h userspace
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- Documentation/misc-devices/mei:mei-amt-version
- tools/firewire:nosy-dump
- tools/iio:generic_buffer
- tools/iio:iio_event_monitor
- tools/iio:lsiio
- tools/power/x86/turbostat:turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
- tools/thermal/tmon:tmon
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
-
- sed -i \
- -e '/^nosy-dump.*LDFLAGS/d' \
- -e '/^nosy-dump.*CFLAGS/d' \
- -e '/^nosy-dump.*CPPFLAGS/s,CPPFLAGS =,CPPFLAGS +=,g' \
- "${S}"/tools/firewire/Makefile
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch}
- #emake prepare modules_prepare ARCH=${karch}
- #touch Module.symvers
-
- # Now we can start building
- append-cflags -I./tools/lib
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Building $dir => $binfile (via emake $target)"
- emake -C $dir ARCH=${karch} $target
- done
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Installing $s => $bin"
- dosbin ${dir}/${bin}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Installing $dir => $binfile"
- dosbin ${dir}/${binfile}
- done
-
- mv -f "${D}"/usr/sbin/{,iio_}generic_buffer
-
- newconfd "${FILESDIR}"/freefall.confd freefall
- newinitd "${FILESDIR}"/freefall.initd freefall
- prune_libtool_files
-}
-
-pkg_postinst() {
- echo
- elog "The cpupower utility is maintained separately at sys-power/cpupower"
- elog "The usbip utility is maintained separately at net-misc/usbip"
- elog "The lguest utility no longer builds, and has been dropped."
- elog "The hpfall tool has been renamed by upstream to freefall; update your config if needed"
- if find /etc/runlevels/ -name hpfall ; then
- ewarn "You must change hpfall to freefall in your runlevels!"
- fi
-}