summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-02 20:30:10 +0100
committerSam James <sam@gentoo.org>2021-03-03 16:51:45 +0000
commitbfb04398bece1a513fbd8a79805eca856dfd2928 (patch)
tree47fecb11955a5ae0e778f831a82e3b122b6f30ee /sys-apps/linux-misc-apps
parentsys-apps/linux-misc-apps: Apply gcc-10 workaround (diff)
downloadgentoo-bfb04398bece1a513fbd8a79805eca856dfd2928.tar.gz
gentoo-bfb04398bece1a513fbd8a79805eca856dfd2928.tar.bz2
gentoo-bfb04398bece1a513fbd8a79805eca856dfd2928.zip
sys-apps/linux-misc-apps: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/linux-misc-apps')
-rw-r--r--sys-apps/linux-misc-apps/Manifest1
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild221
2 files changed, 0 insertions, 222 deletions
diff --git a/sys-apps/linux-misc-apps/Manifest b/sys-apps/linux-misc-apps/Manifest
index cf994b79c8a2..728872c76d94 100644
--- a/sys-apps/linux-misc-apps/Manifest
+++ b/sys-apps/linux-misc-apps/Manifest
@@ -1,2 +1 @@
-DIST linux-5.6.tar.xz 111785252 BLAKE2B 8dbe02a8ca7fd3dcf512a15c5d8098c1e7f94257e65173fed43fcc45480e4ab790df8cd39bbbb4e2a21dc9a00385bc9bbe98215a31e7f7e1d9c8f21cd8ace69e SHA512 80846fe2b4e4a7ff471d2dde28a8216ae807a3209f959e93d39ea4fc9a189ea28ec3db9d303b3fe15a28c2cb90e7446876678e93e23353c2d6f262e364a06bc9
DIST linux-5.8.tar.xz 114459324 BLAKE2B 7bd97f8fa4527840754434414c07283e89731dc8ebb1e95fa5bc1469a60af1122582c0d3b6e262e77882f023190068df3537bd8b65964b3caa820bb2c8e579c7 SHA512 45a53ecf351096ef6e98242cca4228b8da9b9139ecc6963695791ea6fb7a9484a4e1c19dcca7ce7cbfdfa49de0451b70973bb078f12bdae9cbaddbc3f8092556
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild
deleted file mode 100644
index 86827070d512..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild
+++ /dev/null
@@ -1,221 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator eutils toolchain-funcs linux-info autotools flag-o-matic
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="https://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static-libs tcpd usbip"
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v3.x/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.xz
-SRC_URI="${SRC_URI} https://www.kernel.org/pub/linux/kernel/v3.x/${LINUX_SOURCES}"
-
-# pmtools also provides turbostat
-# usbip available in seperate package now
-RDEPEND="sys-apps/hwids
- >=dev-libs/glib-2.6
- >=sys-kernel/linux-headers-$(get_version_component_range 1-2)
- usbip? (
- !net-misc/usbip
- tcpd? ( sys-apps/tcp-wrappers )
- virtual/libudev
- )
- !sys-power/pmtools"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- samples/watchdog/watchdog-simple.c
- tools/accounting/getdelays.c
- tools/cgroup/cgroup_event_listener.c
- tools/laptop/freefall/freefall.c
- tools/testing/selftests/networking/timestamping/timestamping.c
- tools/vm/slabinfo.c
- usr/gen_init_cpio.c
- # Broken:
- #tools/lguest/lguest.c # fails to compile
- #tools/vm/page-types.c # page-types.c:(.text+0xe2b): undefined reference to `debugfs__mount', not defined anywhere
- #tools/net/bpf_jit_disasm.c # /usr/include/x86_64-pc-linux-gnu/bfd.h:35:2: error: #error config.h must be included before this header
-)
-# tools/vm/page-types.c - broken, header path issue
-# tools/hv/hv_kvp_daemon.c - broken in 3.7 by missing linux/hyperv.h userspace
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- samples/mei:mei-amt-version
- tools/firewire:nosy-dump
- tools/iio:iio_event_monitor
- tools/iio:iio_generic_buffer
- tools/iio:lsiio
- tools/laptop/dslm:dslm
- tools/power/x86/turbostat:turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
- tools/thermal/tmon:tmon
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
-
- pushd tools/usb/usbip/ >/dev/null &&
- sed -i 's/-Werror[^ ]* //g' configure.ac &&
- eautoreconf -i -f -v &&
- popd >/dev/null || die "usbip"
-
- sed -i \
- -e '/^nosy-dump.*LDFLAGS/d' \
- -e '/^nosy-dump.*CFLAGS/d' \
- -e '/^nosy-dump.*CPPFLAGS/s,CPPFLAGS =,CPPFLAGS +=,g' \
- "${S}"/tools/firewire/Makefile
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_configure() {
- if use usbip; then
- pushd tools/usb/usbip/ || die
- econf \
- $(use_enable static-libs static) \
- $(use tcpd || echo --without-tcp-wrappers) \
- --with-usbids-dir=/usr/share/misc
- popd
- fi
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch}
- #emake prepare modules_prepare ARCH=${karch}
- #touch Module.symvers
-
- # Now we can start building
- append-cflags -I./tools/lib
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Building $dir => $binfile (via emake $target)"
- emake -C $dir ARCH=${karch} $target
- done
-
- if use usbip; then
- emake -C tools/usb/usbip
- fi
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Installing $s => $bin"
- dosbin ${dir}/${bin}
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target_binfile=${t#*:}
- target=${target_binfile/:*} binfile=${target_binfile/*:}
- [ -z "${binfile}" ] && binfile=$target
- einfo "Installing $dir => $binfile"
- dosbin ${dir}/${binfile}
- done
-
- if use usbip; then
- pushd tools/usb/usbip/ >/dev/null || die "usbip"
- emake DESTDIR="${D}" install
- newdoc README README.usbip
- newdoc AUTHORS AUTHORS.usbip
- popd >/dev/null
- dodoc Documentation/usb/usbip_protocol.rst
- find "${D}" -name 'libusbip*.la' -delete || die
- fi
-
- # At one point upstream it was moved, but be generic to detect if it's
- # happened already
- if [[ -f "${D}"/usr/sbin/generic_buffer ]] && \
- [[ ! -f "${D}"/usr/sbin/iio_generic_buffer ]]; then
- mv -f "${D}"/usr/sbin/{,iio_}generic_buffer || die
- fi
-
- newconfd "${FILESDIR}"/freefall.confd freefall
- newinitd "${FILESDIR}"/freefall.initd freefall
-}
-
-pkg_postinst() {
- echo
- elog "The cpupower utility is maintained separately at sys-power/cpupower"
- elog "The lguest utility no longer builds, and has been dropped."
- elog "The hpfall tool has been renamed by upstream to freefall; update your config if needed"
- if find "${ROOT}"/etc/runlevels/ -name hpfall ; then
- ewarn "You must change hpfall to freefall in your runlevels!"
- fi
- if use usbip; then
- elog "For using USB/IP you need to enable USBIP_VHCI_HCD in the client"
- elog "machine's kernel config and USBIP_HOST on the server."
- fi
-}