summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/lkcdutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/lkcdutils')
-rw-r--r--sys-apps/lkcdutils/Manifest4
-rw-r--r--sys-apps/lkcdutils/files/lkcdutils-6.2.0-build.patch24
-rw-r--r--sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild67
-rw-r--r--sys-apps/lkcdutils/lkcdutils-6.2.0.ebuild35
-rw-r--r--sys-apps/lkcdutils/metadata.xml11
5 files changed, 141 insertions, 0 deletions
diff --git a/sys-apps/lkcdutils/Manifest b/sys-apps/lkcdutils/Manifest
new file mode 100644
index 000000000000..85da3b90ebd7
--- /dev/null
+++ b/sys-apps/lkcdutils/Manifest
@@ -0,0 +1,4 @@
+DIST lkcdutils-4.1-1.src.rpm 1502922 SHA256 3482dfca9f7a766eb8d2778640ed72a6fa621915639f6be1a4e1313ac545df71
+DIST lkcdutils-4.1-dhv8.tar.gz 8227 SHA256 1a7a9e6007c338ece8c8c1459af8c02db0ec624bff5f2f71b5dcab4310a998c0
+DIST lkcdutils-4.1-savedump.tar.gz 21626 SHA256 e3bd94c5a8cc4d97885020c841f47c7aec4fc746a6e3b10ab8840a5dfbc2ca82
+DIST lkcdutils-6.2.0.tar.gz 2967595 SHA256 f69d9eb293ad446d61a882e147120ec3d2f55280443efd859d6cdb196b0de22b
diff --git a/sys-apps/lkcdutils/files/lkcdutils-6.2.0-build.patch b/sys-apps/lkcdutils/files/lkcdutils-6.2.0-build.patch
new file mode 100644
index 000000000000..e8330074d9bd
--- /dev/null
+++ b/sys-apps/lkcdutils/files/lkcdutils-6.2.0-build.patch
@@ -0,0 +1,24 @@
+--- a/libsial/Makefile
++++ b/libsial/Makefile
+@@ -53,7 +53,7 @@
+ ./mkbaseop > baseops.c
+ $(CC) $(CFLAGS) -c baseops.c
+
+-mkbaseop.c sial_member.o sial_op.o sial_stat.o sial_type.o y.tab.o : sial.tab.h
++mkbaseop.c sial_api.o sial_member.o sial_op.o sial_stat.o sial_type.o y.tab.o : sial.tab.h
+
+ lex.sial.o: lex.sial.c sial.tab.c sial.h
+ $(CC) $(CFLAGS) -c lex.sial.c
+--- a/libklib/kl_savedump.c
++++ b/libklib/kl_savedump.c
+@@ -24,6 +24,10 @@
+ #include <unistd.h>
+ #include <linux/stddef.h>
+
++#ifndef offsetof
++#define offsetof(TYPE, MEMBER) ((size_t) &((TYPE *)0)->MEMBER)
++#endif
++
+ static int kl_check_type_dev(char *);
+ static int kl_check_type_dir(char *);
+ static int __kl_dump_retrieve_reg(int,int,char*,int,int);
diff --git a/sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild b/sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild
new file mode 100644
index 000000000000..47c6be3e553e
--- /dev/null
+++ b/sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=${P/4.1.1/4.1}
+DESCRIPTION="Linux Kernel Crash Dumps (LKCD) Utilities"
+HOMEPAGE="http://lkcd.sourceforge.net/ http://oss.software.ibm.com/developerworks/opensource/linux390/june2003_recommended.shtml"
+SRC_URI="http://lkcd.sourceforge.net/download/OLD/4.1.1/lkcdutils/lkcdutils-4.1-1.src.rpm
+ mirror://gentoo/lkcdutils-4.1-savedump.tar.gz
+ mirror://gentoo/lkcdutils-4.1-dhv8.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="s390"
+IUSE=""
+
+DEPEND="app-arch/rpm2targz
+ dev-util/byacc"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ ebegin "Unpacking lkcd distribution..."
+ # This is the same as using rpm2targz then extracting 'cept that
+ # it's faster, less work, and less hard disk space. rpmoffset is
+ # provided by the rpm2targz package.
+ i="${DISTDIR}/${PN}-4.1-1.src.rpm"
+ dd ibs=`rpmoffset < ${i}` skip=1 if=$i 2>/dev/null \
+ | gzip -dc | cpio -idmu 2>/dev/null && tar xzf ${PN}-4.1-1.tar.gz
+ eend ${?}
+ assert "Failed to extract lkcd distribution..."
+
+ unpack lkcdutils-4.1-savedump.tar.gz
+ unpack lkcdutils-4.1-dhv8.tar.gz
+ cd "${S}"
+ epatch ../lkcdutils-4.1-savedump.diff
+ epatch ../lkcdutils-4.1-dhv8.diff
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --bfd_version=2.14.90 || die "configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+ make install ROOT="${D}" || die "install failed"
+ # not needed on s390
+ rm -rf "${D}"/usr/share/sial \
+ "${D}"/usr/lib/libsial.a \
+ "${D}"/usr/include/sial_api.h \
+ "${D}"/usr/include/lkcd/asm/lc_dis.h \
+ "${D}"/etc \
+ "${D}"/sbin/lkcd* \
+ "${D}"/usr/man/man/lkcd*
+ # broken configure script...
+ mv -f "${D}"/usr/man "${D}"/usr/share/man
+}
diff --git a/sys-apps/lkcdutils/lkcdutils-6.2.0.ebuild b/sys-apps/lkcdutils/lkcdutils-6.2.0.ebuild
new file mode 100644
index 000000000000..c61b909da01b
--- /dev/null
+++ b/sys-apps/lkcdutils/lkcdutils-6.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Linux Kernel Crash Dumps (LKCD) Utilities"
+HOMEPAGE="http://lkcd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lkcd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~s390"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ ./configure \
+ --cflags="${CFLAGS} ${CPPFLAGS}" \
+ --lflags="${LDFLAGS}" \
+ || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install ROOT="${D}" || die "install failed"
+ rm -r "${D}"/etc/sysconfig
+}
diff --git a/sys-apps/lkcdutils/metadata.xml b/sys-apps/lkcdutils/metadata.xml
new file mode 100644
index 000000000000..fc290a9782b3
--- /dev/null
+++ b/sys-apps/lkcdutils/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>s390</herd>
+ <maintainer>
+ <email>s390@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">lkcd</remote-id>
+ </upstream>
+</pkgmetadata>