summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-31 22:19:32 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-31 22:21:52 -0400
commitc6e928d9d154ce3c86d89e961bf5afcb1200a440 (patch)
treec19cc8e1a02e7eeb8edbd71ca0c4e3452ca56448 /sys-apps/lshw/files
parentsys-apps/lshw: use https for HOMEPAGE and SRC_URI (diff)
downloadgentoo-c6e928d9d154ce3c86d89e961bf5afcb1200a440.tar.gz
gentoo-c6e928d9d154ce3c86d89e961bf5afcb1200a440.tar.bz2
gentoo-c6e928d9d154ce3c86d89e961bf5afcb1200a440.zip
sys-apps/lshw: remove old
Diffstat (limited to 'sys-apps/lshw/files')
-rw-r--r--sys-apps/lshw/files/lshw-02.17b-fat.patch10
-rw-r--r--sys-apps/lshw/files/lshw-02.17b-gentoo.patch159
-rw-r--r--sys-apps/lshw/files/lshw-02.17b-musl.patch186
3 files changed, 0 insertions, 355 deletions
diff --git a/sys-apps/lshw/files/lshw-02.17b-fat.patch b/sys-apps/lshw/files/lshw-02.17b-fat.patch
deleted file mode 100644
index 08654fd5af6f..000000000000
--- a/sys-apps/lshw/files/lshw-02.17b-fat.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-http://bugs.gentoo.org/485496
-
---- src/core/fat.cc
-+++ src/core/fat.cc
-@@ -82,4 +82,5 @@
- uint8_t pmagic[2];
- } __attribute__((__packed__)) fat32;
-+ char sector[512]; // to make sure the whole struct is at least 512 bytes long
- } __attribute__((__packed__)) type;
- } __attribute__((__packed__));
diff --git a/sys-apps/lshw/files/lshw-02.17b-gentoo.patch b/sys-apps/lshw/files/lshw-02.17b-gentoo.patch
deleted file mode 100644
index 1d3d431ec806..000000000000
--- a/sys-apps/lshw/files/lshw-02.17b-gentoo.patch
+++ /dev/null
@@ -1,159 +0,0 @@
---- lshw-B.02.17.orig/src/Makefile
-+++ lshw-B.02.17/src/Makefile
-@@ -21,11 +21,11 @@
- CXX?=c++
- INCLUDES=-I./core/
- DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
--CXXFLAGS=-g -Wall -g $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
-+CXXFLAGS += -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
- ifeq ($(SQLITE), 1)
- CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
- endif
--LDFLAGS=-L./core/ -g
-+LDFLAGS += -L./core/
- ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
- LDFLAGS+= -Wl,--as-needed
- endif
-@@ -39,27 +39,25 @@
- export LIBS
- export LDFLAGS
-
--DATAFILES = pci.ids usb.ids oui.txt manuf.txt
--
--all: $(PACKAGENAME) $(PACKAGENAME).1 $(DATAFILES)
-+all: $(PACKAGENAME) $(PACKAGENAME).1
-
- .cc.o:
- $(CXX) $(CXXFLAGS) -c $< -o $@
-
- .PHONY: core
- core:
-- +make -C core all
-+ $(MAKE) -C core all
-
- $(PACKAGENAME): core $(PACKAGENAME).o
- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
-
- .PHONY: po
- po:
-- +make -C po all
-+ $(MAKE) -C po all
-
- .PHONY: gui
- gui: core
-- +make -C gui all
-+ $(MAKE) -C gui all
-
- .PHONY: nologo
- nologo:
-@@ -70,7 +68,6 @@
-
- $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
-- $(STRIP) $@
-
- .PHONY: compressed
- compressed: $(PACKAGENAME)-compressed
-@@ -93,14 +90,13 @@
- manuf.txt:
- wget -O $@ http://anonsvn.wireshark.org/wireshark/trunk/manuf
-
--install: all
-+install:
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(SBINDIR)
- $(INSTALL) -m 0755 $(PACKAGENAME) $(DESTDIR)/$(SBINDIR)
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(MANDIR)/man1
- $(INSTALL) -m 0644 $(PACKAGENAME).1 $(DESTDIR)/$(MANDIR)/man1
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(DATADIR)/$(PACKAGENAME)
-- $(INSTALL) -m 0644 $(DATAFILES) $(DESTDIR)/$(DATADIR)/$(PACKAGENAME)
-- make -C po install
-+ $(MAKE) -C po install
-
- install-gui: gui
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(SBINDIR)
-@@ -112,8 +108,8 @@
-
- clean:
- rm -f $(PACKAGENAME).o $(PACKAGENAME) $(PACKAGENAME)-static $(PACKAGENAME)-compressed
-- make -C core clean
-- make -C gui clean
-+ $(MAKE) -C core clean
-+ $(MAKE) -C gui clean
-
- .timestamp:
- date --utc +%Y%m%d%H%M%S > $@
---- lshw-B.02.17.orig/src/core/Makefile
-+++ lshw-B.02.17/src/core/Makefile
-@@ -1,10 +1,9 @@
- PACKAGENAME?=lshw
-
--CXX=c++
-+CXX?=c++
- INCLUDES=
- DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
--CXXFLAGS?=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
--LDFLAGS=
-+CXXFLAGS += -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
- LDSTATIC=
- LIBS=
-
---- lshw-B.02.17.orig/src/core/pci.cc
-+++ lshw-B.02.17/src/core/pci.cc
-@@ -17,7 +17,7 @@
-
- #define PROC_BUS_PCI "/proc/bus/pci"
- #define SYS_BUS_PCI "/sys/bus/pci"
--#define PCIID_PATH DATADIR"/pci.ids:/usr/share/lshw/pci.ids:/usr/local/share/pci.ids:/usr/share/pci.ids:/etc/pci.ids:/usr/share/hwdata/pci.ids:/usr/share/misc/pci.ids"
-+#define PCIID_PATH "/usr/share/misc/pci.ids"
-
- #define PCI_CLASS_REVISION 0x08 /* High 24 bits are class, low 8 revision */
- #define PCI_VENDOR_ID 0x00 /* 16 bits */
---- lshw-B.02.17.orig/src/core/usb.cc
-+++ lshw-B.02.17/src/core/usb.cc
-@@ -27,7 +27,7 @@
-
- #define PROCBUSUSBDEVICES "/proc/bus/usb/devices"
- #define SYSKERNELDEBUGUSBDEVICES "/sys/kernel/debug/usb/devices"
--#define USBID_PATH DATADIR"/usb.ids:/usr/share/lshw/usb.ids:/usr/local/share/usb.ids:/usr/share/usb.ids:/etc/usb.ids:/usr/share/hwdata/usb.ids:/usr/share/misc/usb.ids"
-+#define USBID_PATH "/usr/share/misc/usb.ids"
-
- #define USB_CLASS_PER_INTERFACE 0 /* for DeviceClass */
- #define USB_CLASS_AUDIO 1
---- lshw-B.02.17.orig/src/gui/Makefile
-+++ lshw-B.02.17/src/gui/Makefile
-@@ -1,5 +1,7 @@
- PACKAGENAME?=lshw
-
-+SQLITE?=0
-+
- CXX?=c++
- CC?=cc
- STRIP?=strip
-@@ -8,13 +10,14 @@
- DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
- GTKINCLUDES=$(shell pkg-config gtk+-2.0 --cflags)
- INCLUDES=-I../core $(GTKINCLUDES)
--CXXFLAGS=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
-+CXXFLAGS += -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
- CFLAGS=$(CXXFLAGS) $(DEFINES)
- GTKLIBS=$(shell pkg-config gtk+-2.0 gmodule-2.0 --libs)
--LIBS=-L../core -llshw -lresolv -lsqlite3 $(GTKLIBS)
--LDFLAGS=
--ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
-- LDFLAGS+= -Wl,--as-needed
-+LIBS=-L../core -llshw -lresolv $(GTKLIBS)
-+
-+ifeq ($(SQLITE), 1)
-+ CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
-+ LIBS+= $(shell pkg-config --libs sqlite3)
- endif
-
- OBJS = gtk-lshw.o callbacks.o engine.o print-gui.o stock.o
-@@ -39,7 +42,6 @@
- $(CXX) $(LDFLAGS) -o $@ $^ $(LIBS)
-
- install: all
-- $(STRIP) gtk-$(PACKAGENAME)
-
- clean:
- rm -f $(OBJS) gtk-$(PACKAGENAME) gtk-lshw.glade.bak gtk-lshw.gladep.bak callbacks.c.bak callbacks.h.bak Makefile.bak
diff --git a/sys-apps/lshw/files/lshw-02.17b-musl.patch b/sys-apps/lshw/files/lshw-02.17b-musl.patch
deleted file mode 100644
index 3fb3cef087fa..000000000000
--- a/sys-apps/lshw/files/lshw-02.17b-musl.patch
+++ /dev/null
@@ -1,186 +0,0 @@
---- a/src/core/osutils.cc 2016-02-04 23:47:31.071246925 +0000
-+++ b/src/core/osutils.cc 2016-02-04 23:54:17.125253018 +0000
-@@ -9,6 +9,7 @@
- #include <dirent.h>
- #include <limits.h>
- #include <stdlib.h>
-+#include <stdint.h>
- #include <string.h>
- #include <regex.h>
- #include <ctype.h>
-@@ -496,48 +497,48 @@
-
- unsigned short be_short(const void * from)
- {
-- __uint8_t *p = (__uint8_t*)from;
-+ uint8_t *p = (uint8_t*)from;
-
-- return ((__uint16_t)(p[0]) << 8) +
-- (__uint16_t)p[1];
-+ return ((uint16_t)(p[0]) << 8) +
-+ (uint16_t)p[1];
- }
-
-
- unsigned short le_short(const void * from)
- {
-- __uint8_t *p = (__uint8_t*)from;
-+ uint8_t *p = (uint8_t*)from;
-
-- return ((__uint16_t)(p[1]) << 8) +
-- (__uint16_t)p[0];
-+ return ((uint16_t)(p[1]) << 8) +
-+ (uint16_t)p[0];
- }
-
-
- unsigned long be_long(const void * from)
- {
-- __uint8_t *p = (__uint8_t*)from;
-+ uint8_t *p = (uint8_t*)from;
-
-- return ((__uint32_t)(p[0]) << 24) +
-- ((__uint32_t)(p[1]) << 16) +
-- ((__uint32_t)(p[2]) << 8) +
-- (__uint32_t)p[3];
-+ return ((uint32_t)(p[0]) << 24) +
-+ ((uint32_t)(p[1]) << 16) +
-+ ((uint32_t)(p[2]) << 8) +
-+ (uint32_t)p[3];
- }
-
-
- unsigned long le_long(const void * from)
- {
-- __uint8_t *p = (__uint8_t*)from;
-+ uint8_t *p = (uint8_t*)from;
-
-- return ((__uint32_t)(p[3]) << 24) +
-- ((__uint32_t)(p[2]) << 16) +
-- ((__uint32_t)(p[1]) << 8) +
-- (__uint32_t)p[0];
-+ return ((uint32_t)(p[3]) << 24) +
-+ ((uint32_t)(p[2]) << 16) +
-+ ((uint32_t)(p[1]) << 8) +
-+ (uint32_t)p[0];
-
- }
-
-
- unsigned long long be_longlong(const void * from)
- {
-- __uint8_t *p = (__uint8_t*)from;
-+ uint8_t *p = (uint8_t*)from;
-
- return ((unsigned long long)(p[0]) << 56) +
- ((unsigned long long)(p[1]) << 48) +
-@@ -552,7 +553,7 @@
-
- unsigned long long le_longlong(const void * from)
- {
-- __uint8_t *p = (__uint8_t*)from;
-+ uint8_t *p = (uint8_t*)from;
-
- return ((unsigned long long)(p[7]) << 56) +
- ((unsigned long long)(p[6]) << 48) +
---- a/src/core/device-tree.cc 2016-02-05 00:02:15.539260197 +0000
-+++ b/src/core/device-tree.cc 2016-02-05 00:38:50.523293133 +0000
-@@ -16,6 +16,7 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <stdlib.h>
-+#include <stdint.h>
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
-@@ -24,13 +25,13 @@
- __ID("@(#) $Id: device-tree.cc 2433 2012-01-10 22:01:30Z lyonel $");
-
- #define DIMMINFOSIZE 0x80
--typedef __uint8_t dimminfo_buf[DIMMINFOSIZE];
-+typedef uint8_t dimminfo_buf[DIMMINFOSIZE];
-
- struct dimminfo
- {
-- __uint8_t version3;
-+ uint8_t version3;
- char serial[16];
-- __uint16_t version1, version2;
-+ uint16_t version1, version2;
- };
-
- #define DEVICETREE "/proc/device-tree"
---- a/src/core/pci.cc 2016-02-05 06:02:38.744584655 +0000
-+++ b/src/core/pci.cc 2016-02-05 06:02:20.471584381 +0000
-@@ -7,6 +7,7 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <stdint.h>
-+#include <libgen.h>
- #include <unistd.h>
- #include <stdio.h>
- #include <string.h>
-@@ -1131,9 +1132,9 @@
- string drivername = readlink(string(devices[i]->d_name)+"/driver");
- string modulename = readlink(string(devices[i]->d_name)+"/driver/module");
-
-- device->setConfig("driver", basename(drivername.c_str()));
-+ device->setConfig("driver", basename(const_cast<char *>(drivername.c_str())));
- if(exists(modulename))
-- device->setConfig("module", basename(modulename.c_str()));
-+ device->setConfig("module", basename(const_cast<char *>(modulename.c_str())));
-
- if(exists(string(devices[i]->d_name)+"/rom"))
- {
---- a/src/core/network.cc 2016-02-05 02:20:31.174384674 +0000
-+++ b/src/core/network.cc 2016-02-05 02:21:27.940385526 +0000
-@@ -31,6 +31,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-+#include <stdint.h>
- #include <string.h>
- #include <string>
- #include <sys/types.h>
-@@ -49,9 +50,9 @@
- #define SIOCETHTOOL 0x8946
- #endif
- typedef unsigned long long u64;
--typedef __uint32_t u32;
--typedef __uint16_t u16;
--typedef __uint8_t u8;
-+typedef uint32_t u32;
-+typedef uint16_t u16;
-+typedef uint8_t u8;
-
- struct ethtool_cmd
- {
---- a/src/core/cpufreq.cc 2016-02-05 02:24:29.199388245 +0000
-+++ b/src/core/cpufreq.cc 2016-02-05 02:26:03.283389657 +0000
-@@ -14,6 +14,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <limits.h>
- #include <stdio.h>
- #include <unistd.h>
- #include <dirent.h>
---- a/src/core/abi.cc 2016-02-05 06:13:46.072594669 +0000
-+++ b/src/core/abi.cc 2016-02-05 06:14:19.320595168 +0000
-@@ -11,6 +11,7 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <dirent.h>
-+#include <limits.h>
-
- __ID("@(#) $Id: mem.cc 1352 2006-05-27 23:54:13Z ezix $");
-
-@@ -19,7 +20,7 @@
- bool scan_abi(hwNode & system)
- {
- // are we compiled as 32- or 64-bit process ?
-- system.setWidth(sysconf(_SC_LONG_BIT));
-+ system.setWidth(sysconf(LONG_BIT));
-
- pushd(PROC_SYS);
-