summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-20 11:38:22 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-20 11:40:53 -0400
commit7b458ea982b270ec5a50b2923a4ff9c58ab6fbc0 (patch)
treed4c2e3e014ac1217df86f53c9edfe0d2747baef0 /sys-apps/lshw
parentmedia-libs/imlib2-1.4.9-r0: add alpha keyword (diff)
downloadgentoo-7b458ea982b270ec5a50b2923a4ff9c58ab6fbc0.tar.gz
gentoo-7b458ea982b270ec5a50b2923a4ff9c58ab6fbc0.tar.bz2
gentoo-7b458ea982b270ec5a50b2923a4ff9c58ab6fbc0.zip
sys-apps/lshw: switch to l10n eclass to handle locales
Diffstat (limited to 'sys-apps/lshw')
-rw-r--r--sys-apps/lshw/lshw-02.17b-r2.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/sys-apps/lshw/lshw-02.17b-r2.ebuild b/sys-apps/lshw/lshw-02.17b-r2.ebuild
index 5d7131c8bc0f..bf6c99921945 100644
--- a/sys-apps/lshw/lshw-02.17b-r2.ebuild
+++ b/sys-apps/lshw/lshw-02.17b-r2.ebuild
@@ -3,7 +3,10 @@
# $Id$
EAPI=5
-inherit flag-o-matic eutils toolchain-funcs
+
+PLOCALES='fr'
+
+inherit flag-o-matic eutils toolchain-funcs l10n
MAJ_PV=${PV:0:${#PV}-1}
MIN_PVE=${PV:0-1}
@@ -36,19 +39,11 @@ src_prepare() {
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-fat.patch \
"${FILESDIR}"/${P}-musl.patch
- # correct gettext behavior
- if [[ -n "${LINGUAS+x}" ]] ; then
- local langs
- for i in $(cd src/po ; echo *.po | sed 's/\.po//') ; do
- if has ${i} ${LINGUAS} ; then
- langs+=" ${i}"
- fi
- done
- sed -i \
- -e "/^LANGUAGES =/ s/=.*/= $langs/" \
- src/po/Makefile || die
- fi
+ l10n_find_plocales_changes "src/po" "" ".po" || die
+ sed -i \
+ -e "/^LANGUAGES =/ s/=.*/= $(l10n_get_locales)/" \
+ src/po/Makefile || die
}
src_compile() {