summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-04 11:25:48 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-04 11:25:48 +0100
commitadb0b12fd83f3ddbbe5e50fdc12d9f429214bf67 (patch)
tree8e9b8b20c929f5427f8aa00aa0fd899382ea3824 /sys-apps/man-db/man-db-2.7.6.1-r2.ebuild
parentsys-apps/microcode-ctl: Removed old. (diff)
downloadgentoo-adb0b12fd83f3ddbbe5e50fdc12d9f429214bf67.tar.gz
gentoo-adb0b12fd83f3ddbbe5e50fdc12d9f429214bf67.tar.bz2
gentoo-adb0b12fd83f3ddbbe5e50fdc12d9f429214bf67.zip
sys-apps/man-db: Added sub-slot dep for sys-libs/gdbm
Also reworked econf call a bit. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/man-db/man-db-2.7.6.1-r2.ebuild')
-rw-r--r--sys-apps/man-db/man-db-2.7.6.1-r2.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/sys-apps/man-db/man-db-2.7.6.1-r2.ebuild b/sys-apps/man-db/man-db-2.7.6.1-r2.ebuild
index 783e32df0f9f..b9db3fb1151e 100644
--- a/sys-apps/man-db/man-db-2.7.6.1-r2.ebuild
+++ b/sys-apps/man-db/man-db-2.7.6.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,8 +16,8 @@ IUSE="berkdb +gdbm +manpager nls selinux static-libs zlib"
CDEPEND=">=dev-libs/libpipeline-1.4.0
berkdb? ( sys-libs/db:= )
- gdbm? ( sys-libs/gdbm )
- !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ gdbm? ( sys-libs/gdbm:= )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm:= ) )
sys-apps/groff
zlib? ( sys-libs/zlib )
!sys-apps/man"
@@ -45,15 +45,17 @@ pkg_setup() {
src_configure() {
export ac_cv_lib_z_gzopen=$(usex zlib)
- econf \
- --docdir='$(datarootdir)'/doc/${PF} \
- --with-systemdtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
- --enable-setuid \
- --enable-cache-owner=man \
- --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
- $(use_enable nls) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ --with-systemdtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
+ --enable-setuid
+ --enable-cache-owner=man
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x"
+ $(use_enable nls)
+ $(use_enable static-libs static)
--with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+ )
+ econf "${myeconfargs[@]}"
# Disable color output from groff so that the manpager can add it. #184604
sed -i \