summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/memtest86/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/memtest86/files')
-rw-r--r--sys-apps/memtest86/files/39_memtest8618
-rw-r--r--sys-apps/memtest86/files/memtest86-3.2-solar.patch27
-rw-r--r--sys-apps/memtest86/files/memtest86-3.3-funky-test.patch15
-rw-r--r--sys-apps/memtest86/files/memtest86-3.3-gnu-hash.patch12
-rw-r--r--sys-apps/memtest86/files/memtest86-4.0-build.patch41
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.3-build-nopie.patch47
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.3-build.patch43
7 files changed, 203 insertions, 0 deletions
diff --git a/sys-apps/memtest86/files/39_memtest86 b/sys-apps/memtest86/files/39_memtest86
new file mode 100644
index 000000000000..a736bce6a316
--- /dev/null
+++ b/sys-apps/memtest86/files/39_memtest86
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+. /usr/share/grub/grub-mkconfig_lib
+
+memtest=/boot/memtest86/memtest
+
+if [ -f "${memtest}" ]; then
+ device="$("${grub_probe}" --target=device "${memtest}")"
+ path="$(make_system_path_relative_to_its_root "${memtest}")"
+ cat <<EOF
+menuentry "MemTest86" {
+EOF
+ prepare_grub_to_access_device "${device}" | grub_add_tab
+ cat <<EOF
+ linux16 "${path}"
+}
+EOF
+fi
diff --git a/sys-apps/memtest86/files/memtest86-3.2-solar.patch b/sys-apps/memtest86/files/memtest86-3.2-solar.patch
new file mode 100644
index 000000000000..fa7effbeaac4
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-3.2-solar.patch
@@ -0,0 +1,27 @@
+--- Makefile.orig 2004-11-12 07:16:25.000000000 -0500
++++ Makefile 2005-01-10 21:35:19.000000000 -0500
+@@ -12,7 +12,7 @@
+ #
+ # gcc compiler options, these settings should suffice
+ #
+-CCFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding
++CCFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector
+
+ AS=as -32
+
+@@ -21,10 +21,13 @@
+ all: memtest.bin memtest
+
+ reloc.o: reloc.c
+- $(CC) -c -m32 -fPIC -Wall -O -fno-strict-aliasing reloc.c
++ $(CC) -c -m32 -fPIC -Wall -O -fno-strict-aliasing reloc.c -fno-stack-protector
++
++random.o:
++ $(CC) -c $(CCFLAGS) -fPIC random.c
+
+ test.o: test.c test.h defs.h config.h
+- $(CC) -c $(CCFLAGS) test.c
++ $(CC) -c $(CCFLAGS) -fno-PIC test.c
+
+ main.o: main.c test.h defs.h
+ $(CC) -c $(CCFLAGS) -fPIC main.c
diff --git a/sys-apps/memtest86/files/memtest86-3.3-funky-test.patch b/sys-apps/memtest86/files/memtest86-3.3-funky-test.patch
new file mode 100644
index 000000000000..68fd355b2e08
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-3.3-funky-test.patch
@@ -0,0 +1,15 @@
+i can only guess at what this test was trying to accomplish ...
+
+ive submitted this upstream
+
+--- main.c
++++ main.c
+@@ -465,7 +465,7 @@
+ }
+ compute_segments(window);
+ window = 0;
+- for (v->pass_ticks=0, i=0; i<DEFTESTS != NULL; i++) {
++ for (v->pass_ticks=0, i=0; i<DEFTESTS; i++) {
+
+ /* Test to see if this test is selected for execution */
+ if (v->testsel >= 0) {
diff --git a/sys-apps/memtest86/files/memtest86-3.3-gnu-hash.patch b/sys-apps/memtest86/files/memtest86-3.3-gnu-hash.patch
new file mode 100644
index 000000000000..397b2c8bbee7
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-3.3-gnu-hash.patch
@@ -0,0 +1,12 @@
+sent upstream already ...
+
+--- memtest_shared.lds
++++ memtest_shared.lds
+@@ -19,6 +19,7 @@
+ .dynsym : { *(.dynsym) }
+ .dynstr : { *(.dynstr) }
+ .hash : { *(.hash) }
++ .gnu.hash : { *(.gnu.hash) }
+ .dynamic : { *(.dynamic) }
+
+ .rel.text : { *(.rel.text .rel.text.*) }
diff --git a/sys-apps/memtest86/files/memtest86-4.0-build.patch b/sys-apps/memtest86/files/memtest86-4.0-build.patch
new file mode 100644
index 000000000000..7dfd6c2f6aae
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.0-build.patch
@@ -0,0 +1,41 @@
+--- a/Makefile
++++ b/Makefile
+@@ -8,11 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
++ASFLAGS=-32
+
+-CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
+- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
++CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector $(SMP_FL)
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+@@ -23,7 +21,7 @@
+ # symbols and then link it dynamically so I have full
+ # relocation information
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
++ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+ $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
+
+@@ -50,7 +48,7 @@
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+
+ random.o: random.c
+ $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
+@@ -72,3 +70,6 @@
+ dos: all
+ cat mt86+_loader memtest.bin > memtest.exe
+
++head.o: head.s
++bootsect.o: bootsect.s
++setup.o: setup.s
diff --git a/sys-apps/memtest86/files/memtest86-4.3.3-build-nopie.patch b/sys-apps/memtest86/files/memtest86-4.3.3-build-nopie.patch
new file mode 100644
index 000000000000..adbbe6f86dc7
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.3-build-nopie.patch
@@ -0,0 +1,47 @@
+diff -Naur src.orig/Makefile src/Makefile
+--- src.orig/Makefile 2013-10-10 16:52:14.292140058 -0400
++++ src/Makefile 2013-10-10 16:51:37.431138380 -0400
+@@ -8,11 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
++ASFLAGS=-32
+
+-CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
+- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
++CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector -fno-pie $(SMP_FL)
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+@@ -23,7 +21,7 @@
+ # symbols and then link it dynamically so I have full
+ # relocation information
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
++ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+ $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
+
+@@ -50,10 +48,10 @@
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+
+ random.o: random.c
+- $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
++ $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector -fno-pie random.c
+
+ clean:
+ rm -f *.o *.s *.iso memtest.bin memtest memtest_shared \
+@@ -72,3 +70,7 @@
+ dos: all
+ cat mt86+_loader memtest.bin > memtest.exe
+
++head.o: head.s
++bootsect.o: bootsect.s
++setup.o: setup.s
++
diff --git a/sys-apps/memtest86/files/memtest86-4.3.3-build.patch b/sys-apps/memtest86/files/memtest86-4.3.3-build.patch
new file mode 100644
index 000000000000..2c5906ad5cad
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.3-build.patch
@@ -0,0 +1,43 @@
+diff -uNr src.orig/Makefile src/Makefile
+--- src.orig/Makefile 2013-10-10 19:35:27.354179645 +0100
++++ src/Makefile 2013-10-10 19:38:07.344184547 +0100
+@@ -8,11 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
++ASFLAGS=-32
+
+-CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
+- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
++CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector $(SMP_FL)
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+@@ -23,7 +21,7 @@
+ # symbols and then link it dynamically so I have full
+ # relocation information
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
++ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+ $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
+
+@@ -50,7 +48,7 @@
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+
+ random.o: random.c
+ $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
+@@ -72,3 +70,7 @@
+ dos: all
+ cat mt86+_loader memtest.bin > memtest.exe
+
++head.o: head.s
++bootsect.o: bootsect.s
++setup.o: setup.s
++