summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-04 10:59:51 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-04 11:00:41 +0100
commitfffca5afe1723cb9aac20ede7650d84cf338e15d (patch)
tree3790b572eede3f7a94b9bf71b7d1f85fc89cf012 /sys-apps/microcode-ctl
parentsys-apps/microcode-ctl-1.28-r2: amd64 stable (diff)
downloadgentoo-fffca5afe1723cb9aac20ede7650d84cf338e15d.tar.gz
gentoo-fffca5afe1723cb9aac20ede7650d84cf338e15d.tar.bz2
gentoo-fffca5afe1723cb9aac20ede7650d84cf338e15d.zip
sys-apps/microcode-ctl: Bump to version 1.36
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/Manifest1
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.36.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/microcode-ctl/Manifest b/sys-apps/microcode-ctl/Manifest
index b80549aef65b..84bca224328f 100644
--- a/sys-apps/microcode-ctl/Manifest
+++ b/sys-apps/microcode-ctl/Manifest
@@ -1,3 +1,4 @@
DIST microcode_ctl-1.23.tar.xz 755448 BLAKE2B ad7811536584343254fee8ee77a192834ef3aedac49615d8a4d6dd46f8ad68f01d1a01ee8e54988ade5f6878dc903da0c9f08a93f5efed041cc7bd43c864969c SHA512 f33b4fd43c39b3d4e9b6eb9a12285c7ea26ee43e6c4aa1e45f9aa92a0d2b7d55d1a950ee82d8aea5c86faa15dd1e85e829719b6c772a2c09f262bea630bc7edb
DIST microcode_ctl-1.27.tar.xz 856240 BLAKE2B c9811226e0ad4d26d3ca82b90d8fc34486bb88e7d4e811e543fbd88da8ca2f5cd4b8f9a535f804f2690b0c02e2ac8ab686837a0bf14facd3e792ac1e7502ce1a SHA512 ac4bce583f756b777488605687fe1bef0038763ed4a0afc51b454140f00caf04ef8a6d790d95684aa82c857f9cefd59b2413b96ad3d0c349da4b88166c5aa556
DIST microcode_ctl-1.28.tar.xz 876760 BLAKE2B 8523bdc59ab21a6ec2e1110116bfb4c7a18e859e7f1da65d9e765274b47d5c1909d61eb18017ecc9369b7eedb43cf11cbdc495439aaf1c525bc8d8f7c63ca3a0 SHA512 ed5deb0f96c895b7783c23a1c91d2e03f713a793a21140b049e1b5f08f553dce103b4a11016ebd5076424b1032342d009d952e0089badfea2e91ad486d2cf7f8
+DIST microcode_ctl-1.36.tar.xz 3553884 BLAKE2B 0667971e546a135aba6c49f7eb04908595540ab3ecaebbb175cabda0aeb3396fdb145245a7fab44ec095f447f88e3b78990b22cd4f07568ac4b80ef321109fa1 SHA512 be35b670eba65747aef8bc7a78e989d3481fa0cbfb1635332821da75decef2540f3249ab6ecbe5b95f4d52e9a982cda2c7df31d2f406c0ba27c0354b6b70c2bc
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.36.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.36.ebuild
new file mode 100644
index 000000000000..4ca58a106615
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.36.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs versionator
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel processor microcode update utility"
+HOMEPAGE="https://pagure.io/microcode_ctl"
+SRC_URI="https://releases.pagure.org/${PN/-/_}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="selinux"
+
+DEPEND=""
+RDEPEND=">=sys-firmware/intel-microcode-20090330[monolithic(+)]
+ selinux? ( sec-policy/selinux-cpucontrol )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+}
+
+pkg_preinst() {
+ local _v
+ for _v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 1.28-r1 ${_v}; then
+ # This is an upgrade
+ elog "The init scripts have been removed as they are unsafe. If you want to update"
+ elog "the microcode in your system, please use an initramfs. See bug #528712#41 for"
+ elog "details (and bug #557278 for genkernel users)."
+ fi
+
+ # Show this elog only once
+ break
+ done
+}