summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/mouseemu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/mouseemu')
-rw-r--r--sys-apps/mouseemu/Manifest2
-rw-r--r--sys-apps/mouseemu/files/mouseemu-0.12-fix.diff48
-rw-r--r--sys-apps/mouseemu/files/mouseemu-0.13-fix.patch14
-rw-r--r--sys-apps/mouseemu/files/mouseemu-0.15-build.patch9
-rw-r--r--sys-apps/mouseemu/metadata.xml5
-rw-r--r--sys-apps/mouseemu/mouseemu-0.12.ebuild41
-rw-r--r--sys-apps/mouseemu/mouseemu-0.15.ebuild42
7 files changed, 161 insertions, 0 deletions
diff --git a/sys-apps/mouseemu/Manifest b/sys-apps/mouseemu/Manifest
new file mode 100644
index 000000000000..6c8c00787ebd
--- /dev/null
+++ b/sys-apps/mouseemu/Manifest
@@ -0,0 +1,2 @@
+DIST mouseemu-0.15.tar.gz 13958 SHA256 bbef220a814931f8ee482c82dfd63ad0a8ec895fc7df7bac1a1ada880d59af59
+DIST mouseemu.tar.gz 12019 SHA256 67d5015d2859a58794208278178eabb7b189cb9da106628085c75c7a50f7ee9c
diff --git a/sys-apps/mouseemu/files/mouseemu-0.12-fix.diff b/sys-apps/mouseemu/files/mouseemu-0.12-fix.diff
new file mode 100644
index 000000000000..993f7633e127
--- /dev/null
+++ b/sys-apps/mouseemu/files/mouseemu-0.12-fix.diff
@@ -0,0 +1,48 @@
+--- mouseemu-0.12.orig/Makefile
++++ mouseemu-0.12/Makefile
+@@ -1,6 +1,6 @@
+ all:
+- gcc -Wall -I/usr/src/linux/include -g -o mouseemu mouseemu.c
++ gcc -Wall -g -o mouseemu mouseemu.c
+ clean:
+ rm -f *.o core* mouseemu
+ install:
+- cp -f mouseemu /usr/sbin/
++ cp -f mouseemu $(DESTDIR)/usr/sbin/
+--- mouseemu-0.12.orig/mouseemu.conf
++++ mouseemu-0.12/mouseemu.conf
+@@ -0,0 +1,10 @@
++# Mouseemu Configuration File
++# Each uncommented line is read by the mouseemu initscript
++# (/etc/init.d/mouseemu). If you use mouseemu without the
++# initscript, source this file in your .bashrc/.cshrc/.zshrc
++# Keycodes can be found using the "showkey" program.
++
++#MID_CLICK="-middle 0 68" # F10 with no modifier
++#RIGHT_CLICK="-right 0 87" # F11 with no modifier
++#SCROLL="-scroll 56" # Alt key
++#TYPING_BLOCK="-typing-block 300" # block mouse for 300ms after a keypress
+--- mouseemu-0.12.orig/mouseemu.c
++++ mouseemu-0.12/mouseemu.c
+@@ -428,7 +428,7 @@
+ "\t[-nofork]\n",
+ argv[0]);
+ printf("Key codes can be found in "
+- "/usr/src/linux/include/linux.h,\n"
++ "/usr/src/linux/include/linux/input.h,\n"
+ "or by using `showkey` in console.\n"
+ "Use decimal values. BTN_LEFT(272) is usable as "
+ "B2_KEY or B3_KEY.\n\n");
+--- mouseemu-0.12.orig/mouseemu.init.gentoo.old
++++ mouseemu-0.12/mouseemu.init.gentoo
+@@ -13,6 +13,10 @@
+
+ start() {
+ ebegin "Starting mouseemu"
++ # Source configuration file /etc/mouseemu.conf
++ if [ -f /etc/mouseemu.conf ] ; then
++ . /etc/mouseemu.conf
++ fi
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/mouseemu -- \
+ $MID_CLICK $RIGHT_CLICK $SCROLL $TYPING_BLOCK > /var/log/mouseemu.log
diff --git a/sys-apps/mouseemu/files/mouseemu-0.13-fix.patch b/sys-apps/mouseemu/files/mouseemu-0.13-fix.patch
new file mode 100644
index 000000000000..f4d0aa981762
--- /dev/null
+++ b/sys-apps/mouseemu/files/mouseemu-0.13-fix.patch
@@ -0,0 +1,14 @@
+diff -Naur ../mouseemu.orig/mouseemu.conf ./mouseemu.conf
+--- ../mouseemu.orig/mouseemu.conf 1970-01-01 01:00:00.000000000 +0100
++++ ./mouseemu.conf 2005-02-14 09:10:30.236462888 +0100
+@@ -0,0 +1,10 @@
++# Mouseemu Configuration File
++# Each uncommented line is read by the mouseemu initscript
++# (/etc/init.d/mouseemu). If you use mouseemu without the
++# initscript, source this file in your .bashrc/.cshrc/.zshrc
++# Keycodes can be found using the "showkey" program.
++
++#MID_CLICK="-middle 0 68" # F10 with no modifier
++#RIGHT_CLICK="-right 0 87" # F11 with no modifier
++#SCROLL="-scroll 56" # Alt key
++#TYPING_BLOCK="-typing-block 300" # block mouse for 300ms after a keypress
diff --git a/sys-apps/mouseemu/files/mouseemu-0.15-build.patch b/sys-apps/mouseemu/files/mouseemu-0.15-build.patch
new file mode 100644
index 000000000000..882d66fa7750
--- /dev/null
+++ b/sys-apps/mouseemu/files/mouseemu-0.15-build.patch
@@ -0,0 +1,9 @@
+--- Makefile
++++ Makefile
+@@ -1,5 +1,5 @@
+ all:
+- gcc -Wall -g -o mouseemu mouseemu.c
++ gcc -Wall $(CFLAGS) $(LDFLAGS) -o mouseemu mouseemu.c
+ clean:
+ rm -f *.o core* mouseemu
+ install:
diff --git a/sys-apps/mouseemu/metadata.xml b/sys-apps/mouseemu/metadata.xml
new file mode 100644
index 000000000000..034c09eb248a
--- /dev/null
+++ b/sys-apps/mouseemu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ppc</herd>
+</pkgmetadata>
diff --git a/sys-apps/mouseemu/mouseemu-0.12.ebuild b/sys-apps/mouseemu/mouseemu-0.12.ebuild
new file mode 100644
index 000000000000..b0c33169a8e8
--- /dev/null
+++ b/sys-apps/mouseemu/mouseemu-0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Emulates scrollwheel, right- & left-click for one-button mice/touchpads"
+HOMEPAGE="http://geekounet.org/powerbook/"
+SRC_URI="http://geekounet.org/powerbook/files/${PN}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ppc"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ mv ${WORKDIR}/${PN} ${WORKDIR}/${P}
+ epatch ${FILESDIR}/${P}-fix.diff
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dosbin mouseemu
+ dodoc README COPYING
+ newinitd mouseemu.init.gentoo mouseemu
+ insinto /etc
+ doins mouseemu.conf
+}
+
+pkg_postinst() {
+ einfo "For mouseemu to work you need uinput support in your kernel:"
+ einfo " CONFIG_INPUT_UINPUT=y"
+ einfo "(Device Drivers->Input device support->Misc->User level driver support)"
+ einfo "Don't forget to add mouseemu to your default runlevel:"
+ einfo " rc-update add mouseemu default"
+ einfo "Configuration is in /etc/mouseemu.conf."
+}
diff --git a/sys-apps/mouseemu/mouseemu-0.15.ebuild b/sys-apps/mouseemu/mouseemu-0.15.ebuild
new file mode 100644
index 000000000000..42a1873fc250
--- /dev/null
+++ b/sys-apps/mouseemu/mouseemu-0.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Emulates scrollwheel, right- & left-click for one-button mice/touchpads"
+HOMEPAGE="http://geekounet.org/powerbook/"
+SRC_URI="http://geekounet.org/powerbook/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.13-fix.patch
+ epatch "${FILESDIR}"/${PN}-0.15-build.patch
+}
+
+src_install() {
+ dosbin mouseemu || die
+ dodoc README
+ newinitd mouseemu.init.gentoo mouseemu
+ insinto /etc
+ doins mouseemu.conf
+}
+
+pkg_postinst() {
+ einfo "For mouseemu to work you need uinput support in your kernel:"
+ einfo " CONFIG_INPUT_UINPUT=y"
+ einfo "(Device Drivers->Input device support->Misc->User level driver support)"
+ einfo "Don't forget to add mouseemu to your default runlevel:"
+ einfo " rc-update add mouseemu default"
+ einfo "Configuration is in /etc/mouseemu.conf."
+}