summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/net-tools/net-tools-1.60_p20130513023548.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/net-tools/net-tools-1.60_p20130513023548.ebuild')
-rw-r--r--sys-apps/net-tools/net-tools-1.60_p20130513023548.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/sys-apps/net-tools/net-tools-1.60_p20130513023548.ebuild b/sys-apps/net-tools/net-tools-1.60_p20130513023548.ebuild
new file mode 100644
index 000000000000..7670f816592b
--- /dev/null
+++ b/sys-apps/net-tools/net-tools-1.60_p20130513023548.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://net-tools.git.sourceforge.net/gitroot/net-tools/net-tools"
+ inherit git-2
+else
+ PATCH_VER="1"
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standard Linux networking tools"
+HOMEPAGE="http://net-tools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls old-output selinux static"
+
+RDEPEND="!<sys-apps/openrc-0.9.9.3
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ selinux? ( virtual/pkgconfig )
+ app-arch/xz-utils"
+
+maint_pkg_create() {
+ cd /usr/local/src/net-tools
+ #git-update
+ local stamp=$(date --date="$(git log -n1 --pretty=format:%ci master)" -u +%Y%m%d%H%M%S)
+ local pv="${PV/_p*}_p${stamp}"; pv=${pv/9999/1.60}
+ local p="${PN}-${pv}"
+ git archive --prefix="${p}/" master | tar xf - -C "${T}"
+ pushd "${T}" >/dev/null
+ sed -i "/^RELEASE/s:=.*:=${pv}:" */Makefile || die
+ tar cf - ${p}/ | xz > ${p}.tar.xz
+ popd >/dev/null
+
+ local patches="${p}-patches-${PATCH_VER:-1}"
+ local d="${T}/${patches}"
+ mkdir "${d}"
+ git format-patch -o "${d}" master..gentoo > /dev/null
+ echo "From http://cgit.gentoo.org/proj/net-tools.git" > "${d}"/README
+ tar cf - -C "${T}" ${d##*/} | xz > "${T}"/${patches}.tar.xz
+ rm -rf "${d}"
+
+ du -b "${T}"/*.tar.xz
+}
+
+pkg_setup() { [[ -n ${VAPIER_LOVES_YOU} ]] && maint_pkg_create ; }
+
+set_opt() {
+ local opt=$1 ans
+ shift
+ ans=$("$@" && echo y || echo n)
+ einfo "Setting option ${opt} to ${ans}"
+ sed -i \
+ -e "/^bool.* ${opt} /s:[yn]$:${ans}:" \
+ config.in || die
+}
+
+src_prepare() {
+ if [[ -n ${PATCH_VER} ]] ; then
+ use old-output || EPATCH_EXCLUDE="0001-revert-621a2f376334f8097604b9fee5783e0f1141e66d-for-.patch"
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch "${WORKDIR}"/${P}-patches-${PATCH_VER}
+ fi
+}
+
+src_configure() {
+ set_opt I18N use nls
+ set_opt HAVE_HWIB has_version '>=sys-kernel/linux-headers-2.6'
+ set_opt HAVE_HWTR has_version '<sys-kernel/linux-headers-3.5'
+ set_opt HAVE_HWSTRIP has_version '<sys-kernel/linux-headers-3.6'
+ set_opt SELINUX use selinux
+ if use static ; then
+ append-flags -static
+ append-ldflags -static
+ fi
+ tc-export AR CC
+ yes "" | ./configure.sh config.in || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+ dodoc README README.ipv6 TODO
+}
+
+pkg_postinst() {
+ einfo "etherwake and such have been split into net-misc/ethercard-diag"
+}