summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-07-19 02:57:24 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-07-19 03:11:50 -0400
commitf3ace2e4f395c416ac2f4c1d16bd95aa2610ddb4 (patch)
treefa255b061d1cc57c1611533c7241782a6c4522a0 /sys-apps/paxctld/paxctld-1.2.ebuild
parentapp-emulation/rkt: version bump to 1.10.1 (fixes bug 585208) (diff)
downloadgentoo-f3ace2e4f395c416ac2f4c1d16bd95aa2610ddb4.tar.gz
gentoo-f3ace2e4f395c416ac2f4c1d16bd95aa2610ddb4.tar.bz2
gentoo-f3ace2e4f395c416ac2f4c1d16bd95aa2610ddb4.zip
sys-apps/paxctld: version bump to 1.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-apps/paxctld/paxctld-1.2.ebuild')
-rw-r--r--sys-apps/paxctld/paxctld-1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/paxctld/paxctld-1.2.ebuild b/sys-apps/paxctld/paxctld-1.2.ebuild
new file mode 100644
index 000000000000..765b8aa60b83
--- /dev/null
+++ b/sys-apps/paxctld/paxctld-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit systemd
+
+DESCRIPTION="PaX flags maintenance daemon"
+HOMEPAGE="http://www.grsecurity.net/"
+SRC_URI="https://www.grsecurity.net/${PN}/${PN}_${PV}.orig.tar.gz
+ https://dev.gentoo.org/~blueness/hardened-sources/${PN}/${PN}_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ # Respect Gentoo flags and don't strip
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e '/^LDFLAGS/d' \
+ -e '/STRIP/d' \
+ Makefile
+}
+
+src_install() {
+ default
+
+ systemd_dounit "${S}"/rpm/${PN}.service
+}