summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-30 18:36:31 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-30 18:41:34 +0300
commite5c9521427a3f3a6590baefbd181a8c310b1413c (patch)
tree49b2b65080ba0010c2aa127ef8a29b3505bc878e /sys-apps/pkgcore
parentnet-im/bitlbee: Stabilize 3.6-r3 x86, #873586 (diff)
downloadgentoo-e5c9521427a3f3a6590baefbd181a8c310b1413c.tar.gz
gentoo-e5c9521427a3f3a6590baefbd181a8c310b1413c.tar.bz2
gentoo-e5c9521427a3f3a6590baefbd181a8c310b1413c.zip
sys-apps/pkgcore: add 0.12.15
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.15.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 8931e719f425..e7e6b34fff24 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1,2 +1,3 @@
DIST pkgcore-0.12.13.tar.gz 625121 BLAKE2B add4e54c9d92570f4a4e9dad1af45f7c10e4fa48a312f1dd07b24bede5bf796d523d0a8b8d069234e92db5cf64bfb2911c57e5161ebdb7325bfb336237066b73 SHA512 26267f8ac2c79408467a20decd5fa5b12c075269b3bec155f185349186d920b5273ad1666879ac59caf08af022c2395fe737e2d51f26f9674996767bfbfb9bc6
DIST pkgcore-0.12.14.tar.gz 623778 BLAKE2B 2ac96b45f1aa7b480e5c721c6d354b9b248f1c9111302a1734e33884ada2e7cd62900f6a2162f445f36576beed8fb866952c29728d2084feef7ee492d75b8724 SHA512 760e4491b8613c37e6b88fbded67494a314789fddb78729c7833b7d1678559618c42d9fa10d0c58af1fc9e659766e26b2d9d6d98bf7e90654a2991569defcbff
+DIST pkgcore-0.12.15.tar.gz 623988 BLAKE2B cea8187ec5f02990b5501c0d1d97a1d228de58c78e2be733074f312f1d3a1016722a0a7765b8c4284381082144164f39691c1118e6f5b509e76cf86fb9c410ff SHA512 cc70b9e0afda4958d7dd3889276f3cb3eb3873c3e866c862330ca4e935e022d742bb0e218b09a0ef584a411ef4924ae45da65db9d28147263a578157dae67c7f
diff --git a/sys-apps/pkgcore/pkgcore-0.12.15.ebuild b/sys-apps/pkgcore/pkgcore-0.12.15.ebuild
new file mode 100644
index 000000000000..f1cb1a254268
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.10.0[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ # With PYTHONDONTWRITEBYTECODE=, python will try rebuild all sorts of modules.
+ # https://bugs.gentoo.org/840266
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}