summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-11-22 09:24:35 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-11-22 10:41:27 +0100
commita9b1be867a09888c111a7ffd0977332a381f2693 (patch)
tree416de7e47cff83588bffb62bdadcf2be05d14021 /sys-apps/plocate
parentapp-crypt/swtpm: Bump version to 0.8.0 (diff)
downloadgentoo-a9b1be867a09888c111a7ffd0977332a381f2693.tar.gz
gentoo-a9b1be867a09888c111a7ffd0977332a381f2693.tar.bz2
gentoo-a9b1be867a09888c111a7ffd0977332a381f2693.zip
sys-apps/plocate: add 1.1.17
Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Closes: https://github.com/gentoo/gentoo/pull/28382 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/Manifest1
-rw-r--r--sys-apps/plocate/plocate-1.1.17.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index 7f10636208e0..03941eef0967 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -1 +1,2 @@
DIST plocate-1.1.16.tar.gz 73397 BLAKE2B b6706145e9cba8b386761229cfbf23f8a9490596210b0a8dc467dfa6a6ed5b349c8f84cfcbe0430e89691afb50e257a3d331b1dcdc638611407587c8b623e72b SHA512 01dfc3ba434e6164f3e582fb102bd7ec0167a8f93e4cf9c3e72af804a8eda9b69b04fec20ee34fc19549d810b97076342f3a83b46705d0311ada6004d05da26c
+DIST plocate-1.1.17.tar.gz 73528 BLAKE2B b5694c3669a9717a9410093b1fba2eef029550989ffcbf9b6e7b48cc715c215b909c140cd98d47d30d31ccb6e04fd54e9b565bc8e16c1d9901ccf82a906de311 SHA512 36fa7ad01b5136ce75aad56d154cac511f2f4952a52ef2f16143e46b65a8b129e9011dbdd66d80a0288ef15291864cef0e51d26181b966a2f67b5e4f9fc42c7d
diff --git a/sys-apps/plocate/plocate-1.1.17.ebuild b/sys-apps/plocate/plocate-1.1.17.ebuild
new file mode 100644
index 000000000000..5df0276d30a1
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.17.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.15-meson-use-feature-option-for-libiouring.patch
+)
+
+pkg_setup() {
+ if use io-uring && linux_config_exists; then
+ if ! linux_chkconfig_present IO_URING; then
+ ewarn "CONFIG_IO_URING must be enabled for USE=io-uring"
+ fi
+ fi
+}
+
+src_prepare() {
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ -Dinstall_systemd=true
+ -Dinstall_cron=false
+ -Dsystemunitdir="$(systemd_get_systemunitdir)"
+ "$(meson_feature io-uring use_libiouring)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ # Ensure that the cron file has the same name as the
+ # systemd-timer, to avoid plocate being run twice daily on systems
+ # with a systemd compatiblity layer. See also bug #780351.
+ newins "${FILESDIR}"/plocate.cron plocate-updatedb
+ fperms 0755 /etc/cron.daily/plocate-updatedb
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}