summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-12-09 19:46:48 +0100
committerMichał Górny <mgorny@gentoo.org>2015-12-09 20:06:47 +0100
commite80293dcc6386268b90dd5130409f0069c5de832 (patch)
treef8763925d5cae6e6735ec844cc0df70d9de12675 /sys-apps/portage/portage-9999.ebuild
parentdev-python/suds: Restrict *_all() to python2 when USE=doc (diff)
downloadgentoo-e80293dcc6386268b90dd5130409f0069c5de832.tar.gz
gentoo-e80293dcc6386268b90dd5130409f0069c5de832.tar.bz2
gentoo-e80293dcc6386268b90dd5130409f0069c5de832.zip
sys-apps/portage: Force py2 for doc-build with USE=epydoc
Diffstat (limited to 'sys-apps/portage/portage-9999.ebuild')
-rw-r--r--sys-apps/portage/portage-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index f6dea3e1b2ef..f69e62f70f26 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -78,6 +78,10 @@ prefix_src_archives() {
EGIT_REPO_URI="git://anongit.gentoo.org/proj/portage.git
https://github.com/gentoo/portage.git"
+pkg_setup() {
+ use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
python_prepare_all() {
distutils-r1_python_prepare_all