summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-02-13 20:01:57 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-02-13 20:02:40 +0100
commit25351c5fddc5c9d054bc5f734f2c3476d3d17369 (patch)
tree17152c40920a8a9e6fcf32b4036a63ec8769b974 /sys-apps/qdirstat
parentmetadata/install-qa-check.d/60appdata-path: new check (diff)
downloadgentoo-25351c5fddc5c9d054bc5f734f2c3476d3d17369.tar.gz
gentoo-25351c5fddc5c9d054bc5f734f2c3476d3d17369.tar.bz2
gentoo-25351c5fddc5c9d054bc5f734f2c3476d3d17369.zip
sys-apps/qdirstat: bump to version 1.6.1
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/qdirstat')
-rw-r--r--sys-apps/qdirstat/Manifest1
-rw-r--r--sys-apps/qdirstat/qdirstat-1.6.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
index 61096ddb0424..455c766d6bdb 100644
--- a/sys-apps/qdirstat/Manifest
+++ b/sys-apps/qdirstat/Manifest
@@ -1 +1,2 @@
+DIST qdirstat-1.6.1.tar.gz 7708491 BLAKE2B e6a92f93c76de0f602a66409a2701cd06f1744ab67c3c829938695f1d59b7244998d3a6ddd9d6cfc6408db3ac98d355f4496348ebd198c93ea345b33414c3048 SHA512 fd4c6a3582184785d935e96e884cc3e2033e3ee174ea893816b14524c5c5c62923c5a8c5869969fb8b1d0e84bbffd9dc707a68bdb53898c55dfd14fe16946110
DIST qdirstat-1.6.tar.gz 6398935 BLAKE2B dba15df3f9dd34276ee38ccdd97d1b8158596198b22a807b4d0a68c7d33d146a25ef5b987c4a6e3dc16df421422ddc0cad2e9f60a80493ac668bcb023c15c31c SHA512 8d1350bc8995dac2de90a32ca5ddaac47a317c7e7044f39ed87a7b2e208cda0b84f04c147f7a2414d7a0c5c731479847a879aedcf5781ca772fbfa8fa360cc77
diff --git a/sys-apps/qdirstat/qdirstat-1.6.1.ebuild b/sys-apps/qdirstat/qdirstat-1.6.1.ebuild
new file mode 100644
index 000000000000..e4bae2ee165e
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt-based directory statistics"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ dev-perl/URI
+"
+
+src_prepare() {
+ default
+
+ # Fix QA warning about incorrect use of doc path
+ sed -e "/doc.path/s/${PN}/${PF}/" -i doc/doc.pro doc/stats/stats.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}