summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/razercfg/razercfg-0.30.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/razercfg/razercfg-0.30.ebuild')
-rw-r--r--sys-apps/razercfg/razercfg-0.30.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/sys-apps/razercfg/razercfg-0.30.ebuild b/sys-apps/razercfg/razercfg-0.30.ebuild
new file mode 100644
index 000000000000..876c8ba0757d
--- /dev/null
+++ b/sys-apps/razercfg/razercfg-0.30.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit cmake-utils multilib eutils udev python-single-r1
+
+DESCRIPTION="Utility for advanced configuration of Razer mice (DeathAdder, Krait, Lachesis)"
+
+HOMEPAGE="http://bues.ch/cms/hacking/razercfg.html"
+SRC_URI="http://bues.ch/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pm-utils qt4 systemd +udev"
+
+RDEPEND="qt4? ( >=dev-python/pyside-1.2.1[${PYTHON_USEDEP}] )
+ systemd? ( sys-apps/systemd )
+ udev? ( virtual/udev )
+ pm-utils? ( sys-power/pm-utils )
+ virtual/libusb:1"
+
+DEPEND="virtual/pkgconfig
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/libusb:1"
+
+src_prepare() {
+ sed -i \
+ -e '/udevadm control/{N;d}' \
+ -e '/systemctl/{N;d}' \
+ -e "s:/etc/pm/sleep.d:/usr/$(get_libdir)/pm-utils/sleep.d/:" \
+ -e 's:50-razer:80razer:' \
+ CMakeLists.txt \
+ || die "sed failed"
+
+ sed -i \
+ -e '/ldconfig/{N;d}' \
+ -e "s:DESTINATION lib:DESTINATION $(get_libdir):" \
+ librazer/CMakeLists.txt \
+ || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} -DPYTHON='${PYTHON}'"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}"/razerd.init.d-r2 razerd
+ dodoc README razer.conf
+
+ if ! use qt4; then
+ rm "${D}"/usr/bin/qrazercfg
+ else
+ make_desktop_entry qrazercfg "Razer Mouse Settings" mouse "Qt;Settings"
+ fi
+
+ use pm-utils || rm "${D}"/usr/$(get_libdir)/pm-utils/sleep.d/80razer
+}
+
+pkg_postinst() {
+ use udev && udevadm control --reload-rules && udevadm trigger --subsystem-match=usb
+
+ if [[ -e "${ROOT}"usr/bin/pyrazer.pyc ]]; then
+ echo
+ eerror "A stale ${ROOT}usr/bin/pyrazer.pyc exists and will prevent"
+ eerror "the Python frontends from working until removed manually."
+ echo
+ fi
+}