summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-02-09 19:32:56 +0800
committerJason Zaman <perfinion@gentoo.org>2019-02-09 19:48:31 +0800
commite43398f59c7a1d7d373dd7d29604005bbef1e5f5 (patch)
tree219d9f9e454996b3dee4199c2baae597e4e50e25 /sys-apps/restorecond/restorecond-2.9_rc1.ebuild
parentsys-apps/mcstrans: bump to 2.9_rc1 (diff)
downloadgentoo-e43398f59c7a1d7d373dd7d29604005bbef1e5f5.tar.gz
gentoo-e43398f59c7a1d7d373dd7d29604005bbef1e5f5.tar.bz2
gentoo-e43398f59c7a1d7d373dd7d29604005bbef1e5f5.zip
sys-apps/restorecond: bump to 2.9_rc1
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-apps/restorecond/restorecond-2.9_rc1.ebuild')
-rw-r--r--sys-apps/restorecond/restorecond-2.9_rc1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/restorecond/restorecond-2.9_rc1.ebuild b/sys-apps/restorecond/restorecond-2.9_rc1.ebuild
new file mode 100644
index 000000000000..7e54ae96b8d6
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-2.9_rc1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20190125"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/dbus-glib
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}