summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-30 22:23:46 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-30 22:30:56 -0800
commit81a7a1b371526581bcc6d5671c8952d5a412ea57 (patch)
treecb2b7339663a0d9acf891115fa3dc27f17d312aa /sys-apps/ripgrep
parentnet-misc/freerdp: use cmake.eclass (diff)
downloadgentoo-81a7a1b371526581bcc6d5671c8952d5a412ea57.tar.gz
gentoo-81a7a1b371526581bcc6d5671c8952d5a412ea57.tar.bz2
gentoo-81a7a1b371526581bcc6d5671c8952d5a412ea57.zip
sys-apps/ripgrep: allow building on musl
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/ripgrep')
-rw-r--r--sys-apps/ripgrep/ripgrep-11.0.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-apps/ripgrep/ripgrep-11.0.2.ebuild b/sys-apps/ripgrep/ripgrep-11.0.2.ebuild
index fb7f5349baa8..b01fadb16509 100644
--- a/sys-apps/ripgrep/ripgrep-11.0.2.ebuild
+++ b/sys-apps/ripgrep/ripgrep-11.0.2.ebuild
@@ -95,6 +95,9 @@ BDEPEND="${RDEPEND}
QA_FLAGS_IGNORED="usr/bin/rg"
src_compile() {
+ # allow building on musl with dynamic linking support
+ # https://github.com/BurntSushi/rust-pcre2/issues/7
+ use elibc_musl && export PCRE2_SYS_STATIC=0
cargo_src_compile $(usex pcre "--features pcre2" "")
}