summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/rkflashtool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/rkflashtool')
-rw-r--r--sys-apps/rkflashtool/Manifest1
-rw-r--r--sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h5
-rw-r--r--sys-apps/rkflashtool/metadata.xml11
-rw-r--r--sys-apps/rkflashtool/rkflashtool-5.1.ebuild34
4 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/rkflashtool/Manifest b/sys-apps/rkflashtool/Manifest
new file mode 100644
index 000000000000..e3cb5198608e
--- /dev/null
+++ b/sys-apps/rkflashtool/Manifest
@@ -0,0 +1 @@
+DIST rkflashtool-5.1-src.tar.xz 10548 SHA256 b802b4bd634a614df23f45f65cda8620695282e2646fb5eacd6a69001a110ed6 SHA512 0dbe69dc7fc224e91e170d5630e770e82257121c2215c6e196b2a8450a9e22bab583b57de50acb9aaad223b9d216b731a92260638c648018c319917705983fb2 WHIRLPOOL 6b1de8a5365e55eadb21d2c96c229a2876b31ae9c4a9dade50bebb8eb4e2cc5642ce33213b150487ca546215d47d2cd062f73b958508a6569f3f85c8c396017d
diff --git a/sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h b/sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h
new file mode 100644
index 000000000000..bfffda893a2f
--- /dev/null
+++ b/sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h
@@ -0,0 +1,5 @@
+#ifndef RKFLASHTOOL_VERSION_H
+#define RKFLASHTOOL_VERSION_H
+#define RKFLASHTOOL_VERSION_MAJOR 5
+#define RKFLASHTOOL_VERSION_MINOR 1
+#endif
diff --git a/sys-apps/rkflashtool/metadata.xml b/sys-apps/rkflashtool/metadata.xml
new file mode 100644
index 000000000000..8104459971ba
--- /dev/null
+++ b/sys-apps/rkflashtool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">rkflashtool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/rkflashtool/rkflashtool-5.1.ebuild b/sys-apps/rkflashtool/rkflashtool-5.1.ebuild
new file mode 100644
index 000000000000..a3988d7f386c
--- /dev/null
+++ b/sys-apps/rkflashtool/rkflashtool-5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for flashing Rockchip devices"
+HOMEPAGE="http://sourceforge.net/projects/rkflashtool/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}/${P}-src.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S=${WORKDIR}/${P}-src
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ cp "${FILESDIR}"/${P}-missing-version.h version.h || die
+ sed -i -e "s/CC =/CC ?=/"\
+ -e "s/CFLAGS =/CFLAGS ?=/"\
+ -e "s/LDFLAGS =/LDFLAGS ?=/" Makefile || die
+ tc-export CC
+}
+
+src_install(){
+ dodoc README
+ dobin ${PN} rkcrc rkflashtool rkmisc rkpad rkparameters rkparametersblock rkunpack rkunsign
+}