summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2018-08-22 23:37:21 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-08 17:10:54 -0700
commitb6579a4044b271eb121d2447f13dff67dc83a105 (patch)
tree9d2cbdeb3a21b9d0bc5739c5dcacaa1c7ee1e1b9 /sys-apps/s6/s6-2.7.2.1.ebuild
parentdev-lang/execline: Bump to 2.5.0.1 (diff)
downloadgentoo-b6579a4044b271eb121d2447f13dff67dc83a105.tar.gz
gentoo-b6579a4044b271eb121d2447f13dff67dc83a105.tar.bz2
gentoo-b6579a4044b271eb121d2447f13dff67dc83a105.zip
sys-apps/s6: Bump to 2.7.2.1
Bump EAPI to 7, always compile shared libs, fix bug with USE="static -static-libs", simplify dependency syntax. Closes: https://github.com/gentoo/gentoo/pull/9675 Signed-off-by: Luis Ressel <aranea@aixah.de> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/s6/s6-2.7.2.1.ebuild')
-rw-r--r--sys-apps/s6/s6-2.7.2.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/s6/s6-2.7.2.1.ebuild b/sys-apps/s6/s6-2.7.2.1.ebuild
new file mode 100644
index 000000000000..d91e04cfffd3
--- /dev/null
+++ b/sys-apps/s6/s6-2.7.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static static-libs"
+
+REQUIRED_USE="static? ( static-libs )"
+
+DEPEND=">=dev-lang/execline-2.5.0.1[static-libs?]
+ >=dev-libs/skalibs-2.7.0.0[static-libs?]
+"
+RDEPEND=">=dev-lang/execline-2.5.0.1:=
+ !static? ( >=dev-libs/skalibs-2.7.0.0:= )
+"
+
+DOCS="AUTHORS examples README*"
+HTML_DOCS="doc/*"
+
+src_prepare() {
+ default
+
+ # Remove QA warning about LDFLAGS addition
+ sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
+
+ # configure overrides gentoo's -fstack-protector default
+ sed -i "/^tryflag CFLAGS -fno-stack-protector$/d" "${S}/configure" || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --dynlibdir=/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/$(get_libdir) \
+ --with-lib=/usr/$(get_libdir)/execline \
+ --with-lib=/usr/$(get_libdir)/skalibs \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs \
+ --enable-shared \
+ $(use_enable static allstatic) \
+ $(use_enable static static-libc) \
+ $(use_enable static-libs static)
+}