summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-08-07 22:12:24 +0800
committerJason Zaman <perfinion@gentoo.org>2017-08-08 00:46:49 +0800
commit147b4fc96ab4281c084fa3148d50b3aa68c8c01a (patch)
tree966aa4e1ccbe0d6ff79612b93ce5fa5313f37329 /sys-apps/secilc/secilc-2.7.ebuild
parentsys-apps/semodule-utils: bump to 2.7 (diff)
downloadgentoo-147b4fc96ab4281c084fa3148d50b3aa68c8c01a.tar.gz
gentoo-147b4fc96ab4281c084fa3148d50b3aa68c8c01a.tar.bz2
gentoo-147b4fc96ab4281c084fa3148d50b3aa68c8c01a.zip
sys-apps/secilc: bump to 2.7
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-apps/secilc/secilc-2.7.ebuild')
-rw-r--r--sys-apps/secilc/secilc-2.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/secilc/secilc-2.7.ebuild b/sys-apps/secilc/secilc-2.7.ebuild
new file mode 100644
index 000000000000..7b5cd2063295
--- /dev/null
+++ b/sys-apps/secilc/secilc-2.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit toolchain-funcs
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20170804"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/xmlto
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+RDEPEND="
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}