summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-02-09 19:32:24 +0800
committerJason Zaman <perfinion@gentoo.org>2019-02-09 19:48:26 +0800
commit21ca8f5b0ed12c529a1bd5436da92a9e7f14b9f6 (patch)
treea18b9c3f04d53af00674360222e3ab78c3237546 /sys-apps/secilc/secilc-2.9_rc1.ebuild
parentsys-apps/semodule-utils: bump to 2.9_rc1 (diff)
downloadgentoo-21ca8f5b0ed12c529a1bd5436da92a9e7f14b9f6.tar.gz
gentoo-21ca8f5b0ed12c529a1bd5436da92a9e7f14b9f6.tar.bz2
gentoo-21ca8f5b0ed12c529a1bd5436da92a9e7f14b9f6.zip
sys-apps/secilc: bump to 2.9_rc1
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-apps/secilc/secilc-2.9_rc1.ebuild')
-rw-r--r--sys-apps/secilc/secilc-2.9_rc1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/secilc/secilc-2.9_rc1.ebuild b/sys-apps/secilc/secilc-2.9_rc1.ebuild
new file mode 100644
index 000000000000..d7ad1e7fe883
--- /dev/null
+++ b/sys-apps/secilc/secilc-2.9_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit toolchain-funcs
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20190125"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/xmlto
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+RDEPEND="
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}