summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-18 18:38:33 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-18 18:38:33 -0400
commit1e8b41c1ec1fe0a622eafe91993edd4eb28fcb4e (patch)
tree1681b746769c14b35cac72c05cdf0897ab0b7426 /sys-apps/sg3_utils
parentsys-apps/usbmon: fix build w/newer glibc #580360 (diff)
downloadgentoo-1e8b41c1ec1fe0a622eafe91993edd4eb28fcb4e.tar.gz
gentoo-1e8b41c1ec1fe0a622eafe91993edd4eb28fcb4e.tar.bz2
gentoo-1e8b41c1ec1fe0a622eafe91993edd4eb28fcb4e.zip
sys-apps/sg3_utils: fix build w/newer glibc #580236
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/files/sg3_utils-1.42-sysmacros.patch31
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.42.ebuild3
2 files changed, 33 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/files/sg3_utils-1.42-sysmacros.patch b/sys-apps/sg3_utils/files/sg3_utils-1.42-sysmacros.patch
new file mode 100644
index 000000000000..e8440fb8c322
--- /dev/null
+++ b/sys-apps/sg3_utils/files/sg3_utils-1.42-sysmacros.patch
@@ -0,0 +1,31 @@
+From 13ff34d408cf69339ce1f28756f5c7b5ad5f528b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 18 Apr 2016 18:36:09 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor funcs
+
+These functions are not part of any official spec, and glibc has always
+kept them in sys/sysmacros.h. As glibc moves to conform to POSIX, and
+more alternative C libraries come up, we need to include this header
+explicitly to get the prototypes. Otherwise we fail to build like:
+
+sg_map26.o: In function 'nd_match_scandir_select':
+sg_map26.c:(.text+0x37b): undefined reference to 'major'
+---
+ include/sg_lib.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/sg_lib.h b/include/sg_lib.h
+index b3e741b..a0e483c 100644
+--- a/include/sg_lib.h
++++ b/include/sg_lib.h
+@@ -32,6 +32,7 @@
+
+ #include <stdio.h>
+ #include <stdint.h>
++#include <sys/sysmacros.h>
+
+ #ifdef __cplusplus
+ extern "C" {
+--
+2.7.4
+
diff --git a/sys-apps/sg3_utils/sg3_utils-1.42.ebuild b/sys-apps/sg3_utils/sg3_utils-1.42.ebuild
index 081198b4cf1b..7c366e75c01e 100644
--- a/sys-apps/sg3_utils/sg3_utils-1.42.ebuild
+++ b/sys-apps/sg3_utils/sg3_utils-1.42.ebuild
@@ -20,7 +20,8 @@ RDEPEND=""
PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch #580236
+ epatch "${FILESDIR}"/${PN}-1.42-sysmacros.patch #580236
}
src_configure() {