summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-03-01 17:27:49 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-03-01 17:27:49 -0800
commit3793a1633379b402c2fcb7150378a5fc98cb80e1 (patch)
tree9a6075f73a02be12aea9de72f0510469147f5aa2 /sys-apps/smartmontools
parentsys-apps/smartmontools: Version bump (diff)
downloadgentoo-3793a1633379b402c2fcb7150378a5fc98cb80e1.tar.gz
gentoo-3793a1633379b402c2fcb7150378a5fc98cb80e1.tar.bz2
gentoo-3793a1633379b402c2fcb7150378a5fc98cb80e1.zip
sys-apps/smartmontools: Sync 9999
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index c3e86bfcdb7b..1c0502087af3 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit autotools flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
@@ -22,13 +22,15 @@ IUSE="caps +daemon selinux static systemd +update-drivedb"
DEPEND="
caps? (
- static? ( sys-libs/libcap-ng[static-libs] )
- !static? ( sys-libs/libcap-ng )
+ static? ( sys-libs/libcap-ng:=[static-libs] )
+ !static? ( sys-libs/libcap-ng:= )
)
selinux? (
- sys-libs/libselinux
- )"
-RDEPEND="${DEPEND}
+ sys-libs/libselinux:=
+ )
+"
+RDEPEND="
+ ${DEPEND}
daemon? ( virtual/mailx )
selinux? ( sec-policy/selinux-smartmon )
systemd? ( sys-apps/systemd )
@@ -110,16 +112,16 @@ src_install() {
# Make sure we never install drivedb.h into the db location
# of the acutal image so we don't record hashes because user
# can modify that file
- rm -f "${ED%/}${db_path}/drivedb.h" || die
+ rm -f "${ED}${db_path}/drivedb.h" || die
# Bug #622072
- find "${ED%/}"/usr/share/doc -type f -exec chmod a-x '{}' \; || die
+ find "${ED}"/usr/share/doc -type f -exec chmod a-x '{}' \; || die
}
pkg_postinst() {
if use daemon || use update-drivedb; then
- local initial_db_file="${EROOT}usr/share/${PN}/drivedb.h"
- local db_path="${EROOT}var/db/${PN}"
+ local initial_db_file="${EROOT}/usr/share/${PN}/drivedb.h"
+ local db_path="${EROOT}/var/db/${PN}"
if [[ ! -f "${db_path}/drivedb.h" ]] ; then
# No initial database found