summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-11-06 21:14:27 +0100
committerLouis Sautier <sbraz@gentoo.org>2021-11-06 21:34:49 +0100
commit55ea66e73da3b7d76f05bc512d4b01bf4802155a (patch)
tree61d4adb5b8b3d3f54532294f86a0d9c54af491c7 /sys-apps/smartmontools
parentmail-filter/spampd: Port to EAPI 8 (diff)
downloadgentoo-55ea66e73da3b7d76f05bc512d4b01bf4802155a.tar.gz
gentoo-55ea66e73da3b7d76f05bc512d4b01bf4802155a.tar.bz2
gentoo-55ea66e73da3b7d76f05bc512d4b01bf4802155a.zip
sys-apps/smartmontools: updatedb cron: use new -q option
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/files/smartmontools-7.2-update-smart-drivedb-quiet.patch86
-rw-r--r--sys-apps/smartmontools/files/smartmontools-update-drivedb4
-rw-r--r--sys-apps/smartmontools/smartmontools-7.2-r2.ebuild (renamed from sys-apps/smartmontools/smartmontools-7.2-r1.ebuild)5
3 files changed, 92 insertions, 3 deletions
diff --git a/sys-apps/smartmontools/files/smartmontools-7.2-update-smart-drivedb-quiet.patch b/sys-apps/smartmontools/files/smartmontools-7.2-update-smart-drivedb-quiet.patch
new file mode 100644
index 000000000000..773375508222
--- /dev/null
+++ b/sys-apps/smartmontools/files/smartmontools-7.2-update-smart-drivedb-quiet.patch
@@ -0,0 +1,86 @@
+commit 56363dff436c12eaa296bbba39dfd65ec3f1f1f2
+Author: chrfranke <authors@smartmontools.org>
+Date: Sat Nov 6 15:07:18 2021 +0000
+
+ update-smart-drivedb.in: Add '-q' option to suppress info messages.
+ (GH issues/110).
+ update-smart-drivedb.8.in: Document new option.
+
+ git-svn-id: http://svn.code.sf.net/p/smartmontools/code/trunk@5242 4ea69e1a-61f1-4043-bf83-b5c94c648137
+
+--- a/update-smart-drivedb.8.in
++++ b/update-smart-drivedb.8.in
+@@ -1,6 +1,6 @@
+ .ig
+ Copyright (C) 2013 Hannes von Haugwitz <hannes@vonhaugwitz.com>
+-Copyright (C) 2014-20 Christian Franke
++Copyright (C) 2014-21 Christian Franke
+
+ SPDX-License-Identifier: GPL-2.0-or-later
+
+@@ -144,6 +144,10 @@ Print the OpenPGP/GPG public key block.
+ .B \-\-dryrun
+ Print download commands only.
+ .TP
++.B \-q
++[NEW EXPERIMENTAL UPDATE-SMART-DRIVEDB FEATURE]
++Suppress info messages.
++.TP
+ .B \-v
+ Verbose output.
+ .Sp
+--- a/update-smart-drivedb.in
++++ b/update-smart-drivedb.in
+@@ -72,6 +72,7 @@ Usage: $myname [OPTIONS] [DESTFILE]
+ --no-verify Don't verify signature
+ --export-key Print the OpenPGP/GPG public key block
+ --dryrun Print download commands only
++ -q Suppress info messages
+ -v Verbose output
+
+ Updates $DRIVEDB
+@@ -131,6 +132,11 @@ inpath()
+ return $rc
+ }
+
++iecho()
++{
++ test -n "$quiet" || echo "$*"
++}
++
+ vecho()
+ {
+ test -n "$q" || echo "$*"
+@@ -522,6 +528,7 @@ mv_all()
+ smtctl=$SMARTCTL
+ tool=
+ urlid="svn"
++quiet=
+ q="-q"
+ dryrun=
+ trunk=
+@@ -547,6 +554,9 @@ while true; do case $1 in
+ shift; test -n "$1" || usage
+ urlid=$1 ;;
+
++ -q)
++ quiet=t ;;
++
+ -v)
+ q= ;;
+
+@@ -727,7 +737,7 @@ if [ -f "$DEST" ]; then
+ then
+ rm -f "$DEST.new" "$DEST.new.raw" "$DEST.new.raw.asc"
+ touch "$DEST.lastcheck"
+- echo "$DEST is already up to date"
++ iecho "$DEST is already up to date"
+ exit 0
+ fi
+ mv_all "$DEST" "" ".old"
+@@ -738,4 +748,4 @@ fi
+
+ mv_all "$DEST" ".new" ""
+
+-echo "$DEST updated from ${trunk:-branches/$brnch}${no_verify:+ (NOT VERIFIED)}"
++iecho "$DEST updated from ${trunk:-branches/$brnch}${no_verify:+ (NOT VERIFIED)}"
diff --git a/sys-apps/smartmontools/files/smartmontools-update-drivedb b/sys-apps/smartmontools/files/smartmontools-update-drivedb
index b7d1bb95243f..270789c53d0a 100644
--- a/sys-apps/smartmontools/files/smartmontools-update-drivedb
+++ b/sys-apps/smartmontools/files/smartmontools-update-drivedb
@@ -1,5 +1,3 @@
#!/bin/sh
-# Hide stdout until a --quiet switch is added:
-# https://github.com/smartmontools/smartmontools/issues/110
-/usr/sbin/update-smart-drivedb > /dev/null
+/usr/sbin/update-smart-drivedb -q
diff --git a/sys-apps/smartmontools/smartmontools-7.2-r1.ebuild b/sys-apps/smartmontools/smartmontools-7.2-r2.ebuild
index 39f90ac1de44..3059ff0feb50 100644
--- a/sys-apps/smartmontools/smartmontools-7.2-r1.ebuild
+++ b/sys-apps/smartmontools/smartmontools-7.2-r2.ebuild
@@ -48,6 +48,11 @@ REQUIRED_USE="(
static? ( !systemd )
)"
+PATCHES=(
+ # Backport from commit 56363dff436c12eaa296bbba39dfd65ec3f1f1f2
+ "${FILESDIR}/${P}-update-smart-drivedb-quiet.patch"
+)
+
src_prepare() {
default
eautoreconf