summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-02 00:08:19 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-02 00:18:54 +0200
commit6076a85af5dfa444faeddefaac997dcadac1f303 (patch)
tree3ffafc3e020223ff297ab4335e14caf5aa072e11 /sys-apps/superdiag
parentsys-apps/smcipmitool: drop old version (diff)
downloadgentoo-6076a85af5dfa444faeddefaac997dcadac1f303.tar.gz
gentoo-6076a85af5dfa444faeddefaac997dcadac1f303.tar.bz2
gentoo-6076a85af5dfa444faeddefaac997dcadac1f303.zip
sys-apps/superdiag: bump to version 1.5.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/superdiag')
-rw-r--r--sys-apps/superdiag/Manifest1
-rw-r--r--sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-apps/superdiag/Manifest b/sys-apps/superdiag/Manifest
index b85511c555c7..04483bff487b 100644
--- a/sys-apps/superdiag/Manifest
+++ b/sys-apps/superdiag/Manifest
@@ -1 +1,2 @@
DIST SuperDiag_1.4.0_20201120.zip 5537813 BLAKE2B 014a3770944fdf9f9396e894320cfa65acebc63cfc1f396b4170a351813b72cca5902a27df21f62bf04a25ab5f9db306795ab108d8669045a205f990b1ef73a1 SHA512 d1e33f0fcb22c0b3794dd3677efa6d1041c81cdf09b92e297035a907e4110482daf896c109437380750ad2905008651b017718e97b1ca1e9f8ceee8c24ee0943
+DIST SuperDiag_1.5.0_20210507.zip 5039420 BLAKE2B bd249b7c2517857ce9079e3691cb31b3982dd097f11eb09288caff660d7f5e4a779519081cd27f89137d8173ad5419189122bc42bba5374f81f20c86f9e3e106 SHA512 ed457da1204b8670163f1186618b672cf088426461a1fb56c1bd618268e4f4420cd94bf05b62b3d6964499100583fe8ce72ced3ff8bafde3ac7db5c3ca0842e1
diff --git a/sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild b/sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild
new file mode 100644
index 000000000000..cea0aa94f07e
--- /dev/null
+++ b/sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="SuperDiag"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Provides the capability to determine the health of Supermicro servers components"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+IUSE="iso usb"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SDO"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unpack ${A}
+
+ if use iso; then
+ unzip Diagnose_Remotely/ISOFor${MY_PN}_${MY_PV}.zip -d iso || die
+ fi
+
+ if use usb; then
+ unzip Diagnose_Remotely/USBFor${MY_PN}_${MY_PV}.zip -d usb || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/superdiag
+ doins startup.nsh ${MY_PN}.efi EFI/Boot/BootX64.efi
+
+ local DOCS=(
+ "Supermicro Super Diagnostics Offline readme.txt"
+ "Supermicro Super Diagnostics Offline User Guide V${MY_PV}.pdf"
+ )
+ dodoc "${DOCS[@]}"
+
+ if use iso; then
+ insinto /usr/share/superdiag/ISO
+ doins iso/${MY_PN}_${MY_PV}.iso
+
+ newdoc iso/Readme.txt Readme.ISO.txt
+ fi
+
+ if use usb; then
+ insinto /usr/share/superdiag/USB
+ doins usb/startup.nsh
+
+ dosym ../BootX64.efi /usr/share/superdiag/USB/BootX64.efi
+ dosym ../${MY_PN}.efi /usr/share/superdiag/USB/${MY_PN}.efi
+
+ newdoc usb/Readme.txt Readme.USB.txt
+ fi
+}