summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-02-17 10:49:11 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-02-17 10:49:29 -0800
commitfad8143675dd45c9f725c02bd94bf8fe815851e3 (patch)
treed92af42e070adcd51bd720270c4d321d42d8f714 /sys-apps/systemd-tmpfiles
parentapp-misc/tracker-miners: Stabilize 2.3.5 amd64, #768753 (diff)
downloadgentoo-fad8143675dd45c9f725c02bd94bf8fe815851e3.tar.gz
gentoo-fad8143675dd45c9f725c02bd94bf8fe815851e3.tar.bz2
gentoo-fad8143675dd45c9f725c02bd94bf8fe815851e3.zip
sys-apps/systemd-tmpfiles: fix build on recent musl
Thanks-to: ernsteiswuerfel <erhard_f@mailbox.org> Closes: https://bugs.gentoo.org/766833 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/systemd-tmpfiles')
-rw-r--r--sys-apps/systemd-tmpfiles/files/musl-1.2.2.patch14
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/sys-apps/systemd-tmpfiles/files/musl-1.2.2.patch b/sys-apps/systemd-tmpfiles/files/musl-1.2.2.patch
new file mode 100644
index 000000000000..dc8905d5aabc
--- /dev/null
+++ b/sys-apps/systemd-tmpfiles/files/musl-1.2.2.patch
@@ -0,0 +1,14 @@
+diff --git a/meson.build b/meson.build
+index bea9935..03b40f2 100644
+--- a/meson.build
++++ b/meson.build
+@@ -510,7 +510,8 @@ foreach ident : [
+ #include <sys/stat.h>
+ #include <unistd.h>'''],
+ ['explicit_bzero' , '''#include <string.h>'''],
+- ['reallocarray', '''#include <malloc.h>'''],
++ ['reallocarray', '''#include <malloc.h>
++ #include <stdlib.h>'''],
+ ['set_mempolicy', '''#include <stdlib.h>
+ #include <unistd.h>'''],
+ ['get_mempolicy', '''#include <stdlib.h>
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
index e4e1196d3663..d12d038db90a 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
@@ -53,6 +53,7 @@ src_prepare() {
# musl patchset from:
# http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/systemd/systemd
use elibc_musl && eapply "${WORKDIR}/${P}-musl"
+ use elibc_musl && eapply "${FILESDIR}/musl-1.2.2.patch" # https://bugs.gentoo.org/766833
default
}