summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/systemd-ui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/systemd-ui')
-rw-r--r--sys-apps/systemd-ui/Manifest1
-rw-r--r--sys-apps/systemd-ui/files/systemd-ui-3-vala-0.24.patch35
-rw-r--r--sys-apps/systemd-ui/metadata.xml8
-rw-r--r--sys-apps/systemd-ui/systemd-ui-3.ebuild48
-rw-r--r--sys-apps/systemd-ui/systemd-ui-9999.ebuild60
5 files changed, 152 insertions, 0 deletions
diff --git a/sys-apps/systemd-ui/Manifest b/sys-apps/systemd-ui/Manifest
new file mode 100644
index 000000000000..467f94d50994
--- /dev/null
+++ b/sys-apps/systemd-ui/Manifest
@@ -0,0 +1 @@
+DIST systemd-ui-3.tar.xz 153680 SHA256 455e65000abf39bbccd937786b5f0d7c76ea631b6f28d7142f007fa141338dad SHA512 babc81dc6c205b3b95d19b4c762e2658c02942db884384f25324f63b4dca3cdafdb1b12e1a63ff33f9ff0c8152529cc700a1173c888cf4f6e3a9f0992889c9cd WHIRLPOOL 8f4f9b07c9debf2396581652ea8192bea954a25b8bd94157b0f7f836a6290c62b1ed82df61bdb48a3597774337ce3f4cfdd60c8799e73db92b25a35c9f3e5ab0
diff --git a/sys-apps/systemd-ui/files/systemd-ui-3-vala-0.24.patch b/sys-apps/systemd-ui/files/systemd-ui-3-vala-0.24.patch
new file mode 100644
index 000000000000..ce5df6c75ce9
--- /dev/null
+++ b/sys-apps/systemd-ui/files/systemd-ui-3-vala-0.24.patch
@@ -0,0 +1,35 @@
+From 282a352dff49c13e185d826af2a248b55988bc32 Mon Sep 17 00:00:00 2001
+From: Michael Biebl <biebl@debian.org>
+Date: Tue, 29 Apr 2014 20:20:51 +0000
+Subject: Fix ambiguity between `GLib.Notification' and `Notify.Notification'
+
+Notification is both defined by Notify and the latest GLib, resulting in
+a build failure. Use Notify.Notification instead to avoid this
+ambiguity.
+
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=746130
+---
+diff --git a/src/gnome-ask-password-agent.vala b/src/gnome-ask-password-agent.vala
+index 571cd94..f3887dd 100644
+--- a/src/gnome-ask-password-agent.vala
++++ b/src/gnome-ask-password-agent.vala
+@@ -80,7 +80,7 @@ public class MyStatusIcon : StatusIcon {
+ string socket;
+
+ PasswordDialog password_dialog;
+- Notification n;
++ Notify.Notification n;
+
+ public MyStatusIcon() throws GLib.Error {
+ GLib.Object(icon_name : "dialog-password");
+@@ -183,7 +183,7 @@ public class MyStatusIcon : StatusIcon {
+ }
+ set_from_icon_name(icon);
+
+- n = new Notification(title, message, icon);
++ n = new Notify.Notification(title, message, icon);
+ n.set_timeout(5000);
+ n.closed.connect(() => {
+ set_visible(true);
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/sys-apps/systemd-ui/metadata.xml b/sys-apps/systemd-ui/metadata.xml
new file mode 100644
index 000000000000..fe305d209585
--- /dev/null
+++ b/sys-apps/systemd-ui/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>systemd@gentoo.org</email>
+ <name>Gentoo systemd team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/systemd-ui/systemd-ui-3.ebuild b/sys-apps/systemd-ui/systemd-ui-3.ebuild
new file mode 100644
index 000000000000..60875aa42aa8
--- /dev/null
+++ b/sys-apps/systemd-ui/systemd-ui-3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Needed per https://bugs.freedesktop.org/show_bug.cgi?id=69643#c5
+VALA_MIN_API_VERSION=0.22
+
+inherit autotools-utils systemd vala
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ !sys-apps/systemd[gtk]
+ >=dev-libs/glib-2.26:2
+ dev-libs/libgee:0.8
+ sys-apps/dbus
+ x11-libs/gtk+:3
+ >=x11-libs/libnotify-0.7
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ $(vala_depend)
+"
+
+# Due to vala being broken.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}/${P}-vala-0.24.patch" )
+
+src_prepare() {
+ # Force the rebuild of .vala sources
+ touch src/*.vala || die
+
+ # Fix hardcoded path in .vala.
+ sed -i -e "s^/lib/systemd^$(systemd_get_utildir)^g" src/*.vala || die
+
+ autotools-utils_src_prepare
+ vala_src_prepare
+}
diff --git a/sys-apps/systemd-ui/systemd-ui-9999.ebuild b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
new file mode 100644
index 000000000000..8812d56b4097
--- /dev/null
+++ b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/${PN}
+ http://cgit.freedesktop.org/systemd/${PN}/"
+
+inherit git-2
+#endif
+
+# Needed per https://bugs.freedesktop.org/show_bug.cgi?id=69643#c5
+VALA_MIN_API_VERSION=0.22
+
+inherit autotools-utils systemd vala
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/systemd[gtk]
+ >=dev-libs/glib-2.26
+ dev-libs/libgee:0.8
+ sys-apps/dbus
+ x11-libs/gtk+:3
+ >=x11-libs/libnotify-0.7"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ $(vala_depend)"
+
+#if LIVE
+SRC_URI=
+KEYWORDS=
+
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.2"
+#endif
+
+# Due to vala being broken.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Force the rebuild of .vala sources
+ touch src/*.vala || die
+
+ # Fix hardcoded path in .vala.
+ sed -i -e "s^/lib/systemd^$(systemd_get_utildir)^g" src/*.vala || die
+
+ autotools-utils_src_prepare
+ vala_src_prepare
+}