summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-07-30 20:44:01 -0400
committerMike Gilbert <floppym@gentoo.org>2016-07-30 20:46:02 -0400
commit95351937678850ab86d4bd0f8819a80c594578d0 (patch)
tree9119a5992d896d7cd38dfd5fe9d042513a95ebdd /sys-apps/systemd/systemd-231.ebuild
parentsys-apps/systemd: fix resolv.conf message (diff)
downloadgentoo-95351937678850ab86d4bd0f8819a80c594578d0.tar.gz
gentoo-95351937678850ab86d4bd0f8819a80c594578d0.tar.bz2
gentoo-95351937678850ab86d4bd0f8819a80c594578d0.zip
sys-apps/systemd: skip DEVPTS_MULTIPLE_INSTANCES check for Linux >= 4.7
Thanks to novns in #gentoo-systemd.
Diffstat (limited to 'sys-apps/systemd/systemd-231.ebuild')
-rw-r--r--sys-apps/systemd/systemd-231.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-231.ebuild b/sys-apps/systemd/systemd-231.ebuild
index b4f261317768..26e4effa9228 100644
--- a/sys-apps/systemd/systemd-231.ebuild
+++ b/sys-apps/systemd/systemd-231.ebuild
@@ -105,7 +105,7 @@ python_check_deps() {
pkg_pretend() {
local CONFIG_CHECK="~AUTOFS4_FS ~BLK_DEV_BSG ~CGROUPS
- ~DEVPTS_MULTIPLE_INSTANCES ~DEVTMPFS ~DMIID ~EPOLL ~FANOTIFY ~FHANDLE
+ ~DEVTMPFS ~DMIID ~EPOLL ~FANOTIFY ~FHANDLE
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SECCOMP ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX
~!FW_LOADER_USER_HELPER ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
@@ -113,6 +113,7 @@ pkg_pretend() {
use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"
kernel_is -lt 3 7 && CONFIG_CHECK+=" ~HOTPLUG"
+ kernel_is -lt 4 7 && CONFIG_CHECK+=" ~DEVPTS_MULTIPLE_INSTANCES"
if linux_config_exists; then
local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)