summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-12-30 20:22:17 -0500
committerMike Gilbert <floppym@gentoo.org>2017-12-30 20:25:36 -0500
commit0a0bc30e66759255f4d84527f09c2ccc00fbe0ca (patch)
treef3ce21f60108ce9d7e1205dd5c81d17ca0754b04 /sys-apps/systemd
parentvmware-bundle.eclass: mark @DEAD (diff)
downloadgentoo-0a0bc30e66759255f4d84527f09c2ccc00fbe0ca.tar.gz
gentoo-0a0bc30e66759255f4d84527f09c2ccc00fbe0ca.tar.bz2
gentoo-0a0bc30e66759255f4d84527f09c2ccc00fbe0ca.zip
sys-apps/systemd: avoid infinite exec recursion in telinit
Closes: https://bugs.gentoo.org/642724 Package-Manager: Portage-2.3.19_p3, Repoman-2.3.6_p37
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/systemd-236-r3.ebuild (renamed from sys-apps/systemd/systemd-236-r2.ebuild)2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-236-r2.ebuild b/sys-apps/systemd/systemd-236-r3.ebuild
index 276c398c8a9a..fe6cc466dc03 100644
--- a/sys-apps/systemd/systemd-236-r2.ebuild
+++ b/sys-apps/systemd/systemd-236-r3.ebuild
@@ -205,6 +205,8 @@ multilib_src_configure() {
-Drootprefix="$(usex usrmerge "${EPREFIX}/usr" "${EPREFIX:-/}")"
-Dsysvinit-path=
-Dsysvrcnd-path=
+ # Avoid infinite exec recursion, bug 642724
+ -Dtelinit-path="${EPREFIX}/lib/sysvinit/telinit"
# no deps
-Defi=$(meson_multilib)
-Dima=true
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index f8eb096a861c..84ede7fddf88 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -204,6 +204,8 @@ multilib_src_configure() {
-Drootprefix="$(usex usrmerge "${EPREFIX}/usr" "${EPREFIX:-/}")"
-Dsysvinit-path=
-Dsysvrcnd-path=
+ # Avoid infinite exec recursion, bug 642724
+ -Dtelinit-path="${EPREFIX}/lib/sysvinit/telinit"
# no deps
-Defi=$(meson_multilib)
-Dima=true